aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNguyễn Gia Phong <mcsinyx@disroot.org>2024-09-26 09:21:29 +0000
committerLudovic Courtès <ludo@gnu.org>2024-09-30 20:52:23 +0000
commitf0a1915564c11a8f7188c486ab38ed7d29ea0bb5 (patch)
treea158837e102acd6b43769554c6565c8e98d31dbd
parentc51d7fd569c71b0d715697358053296b156f9aac (diff)
downloadguix-f0a1915564c11a8f7188c486ab38ed7d29ea0bb5.tar
guix-f0a1915564c11a8f7188c486ab38ed7d29ea0bb5.tar.gz
guix-f0a1915564c11a8f7188c486ab38ed7d29ea0bb5.tar.bz2
guix-f0a1915564c11a8f7188c486ab38ed7d29ea0bb5.tar.lz
guix-f0a1915564c11a8f7188c486ab38ed7d29ea0bb5.tar.xz
guix-f0a1915564c11a8f7188c486ab38ed7d29ea0bb5.tar.zst
guix-f0a1915564c11a8f7188c486ab38ed7d29ea0bb5.zip
gnu: dyninst: Remove patch-bad-logic phase.
The short circuit logic (return failure to resolve library path if ldconfig not found) is no longer present on Dyninst 13. * gnu/packages/instrumentation.scm (dyninst): Remove patch-bad-logic phase. Fixes: 254c8f2c8cbb ("gnu: dyninst: Update to 13.0.0.") References: https://github.com/dyninst/dyninst/pull/1362 Change-Id: I021ec71416da90d11705ef04fba7c170558ef3c6 Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/instrumentation.scm15
1 files changed, 0 insertions, 15 deletions
diff --git a/gnu/packages/instrumentation.scm b/gnu/packages/instrumentation.scm
index 1b99399913..86436130c9 100644
--- a/gnu/packages/instrumentation.scm
+++ b/gnu/packages/instrumentation.scm
@@ -222,23 +222,8 @@ standard library headers.")
;; source.
#:configure-flags
(list "-DSTERILE_BUILD=ON")
- ;; NOTE: dyninst needs to search for shared libraries that are linked
- ;; against the instrumented binary in order to rebuild the entire
- ;; program. For this purpose, one can use LD_LIBRARY_PATH or
- ;; DYNISNT_REWRITER_PATHS environment variables to add paths for dyinst
- ;; to search. However, dyninst also tries to be smart by executing
- ;; ldconfig, which is not portable. If ldconfig is not available on
- ;; the system, dyinst wrongly assumes that the shared libraries can not
- ;; be found, even though it can. This bad logic is still there with
- ;; newer versions of dyinst. Thus, this substitution makes the bad
- ;; code path unreachable.
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'patch-bad-logic
- (lambda _
- (substitute* "dyninstAPI/src/linux.C"
- (("if\\(fgets\\(buffer, buffer_size, ldconfig\\)\\)")
- "fgets(buffer, buffer_size, ldconfig); if (true)"))))
(add-after 'unpack 'adjust-supported-platform-name
(lambda _
;; That file checks for "i386" but