aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRomain GARBAGE <romain.garbage@inria.fr>2024-09-24 11:12:27 +0000
committerLudovic Courtès <ludo@gnu.org>2024-09-30 20:52:23 +0000
commitc51d7fd569c71b0d715697358053296b156f9aac (patch)
tree0037f49782611d12978a165f67983f17192b7479
parent210bbf9a391612a4e28883a288168d9a23fe66b9 (diff)
downloadguix-c51d7fd569c71b0d715697358053296b156f9aac.tar
guix-c51d7fd569c71b0d715697358053296b156f9aac.tar.gz
guix-c51d7fd569c71b0d715697358053296b156f9aac.tar.bz2
guix-c51d7fd569c71b0d715697358053296b156f9aac.tar.lz
guix-c51d7fd569c71b0d715697358053296b156f9aac.tar.xz
guix-c51d7fd569c71b0d715697358053296b156f9aac.tar.zst
guix-c51d7fd569c71b0d715697358053296b156f9aac.zip
gnu: netcdf-parallel-openmpi: Build shared library.
* gnu/packages/maths.scm (netcdf-parallel-openmpi) [arguments]: Enable building of shared library. Change-Id: I6e901d5939108421e041252207f10f4800890e97 Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/maths.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 5f47d5e390..03fa4d2fae 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -2363,8 +2363,9 @@ sharing of scientific data.")
((#:configure-flags flags)
`(cons* "CC=mpicc" "CXX=mpicxx"
"--enable-parallel-tests"
- ;; Shared libraries not supported with parallel IO.
- "--disable-shared" "--with-pic"
+ ;; NetCDF supports both parallel and shared library building
+ ;; See https://docs.unidata.ucar.edu/nug/current/getting_and_building_netcdf.html#build_parallel
+ "--enable-shared" "--with-pic"
,flags))
((#:phases phases '%standard-phases)
`(modify-phases ,phases