aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-08-29 16:25:46 +0000
committerLudovic Courtès <ludo@gnu.org>2024-10-04 17:43:39 +0000
commited0d985385cc4c45c9da2cc0886e454d261f3720 (patch)
tree61cd341a81e0d9d357c714f22234f0d8ed2c5ac1
parent8570fccfa78ab8a0c925b73494b055378fa57163 (diff)
downloadguix-ed0d985385cc4c45c9da2cc0886e454d261f3720.tar
guix-ed0d985385cc4c45c9da2cc0886e454d261f3720.tar.gz
guix-ed0d985385cc4c45c9da2cc0886e454d261f3720.tar.bz2
guix-ed0d985385cc4c45c9da2cc0886e454d261f3720.tar.lz
guix-ed0d985385cc4c45c9da2cc0886e454d261f3720.tar.xz
guix-ed0d985385cc4c45c9da2cc0886e454d261f3720.tar.zst
guix-ed0d985385cc4c45c9da2cc0886e454d261f3720.zip
gnu: scilab: Add sanity-check phase.
* gnu/packages/maths.scm (scilab): [arguments]<#:phases>: Add sanity-check phase. Change-Id: Idc6911511fd0bf7e779d4af026f0a6390eb3b079 Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/maths.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index ba49edb0c3..f3d5be7aba 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -10113,7 +10113,12 @@ computation is supported via MPI.")
"\"${XDG_STATE_HOME:-$HOME/.local/state}/scilab/"
#$(package-version this-package) "\""))
(("export SCI=")
- "unset LANGUAGE\nexport SCI="))))))))
+ "unset LANGUAGE\nexport SCI="))))
+ (add-after 'rewrap-scilab-cli 'sanity-check
+ (lambda _
+ (setenv "HOME" (getcwd))
+ (invoke (string-append #$output "/bin/scilab-cli")
+ "-e" "\"quit;\"")))))))
(home-page "https://www.scilab.org/")
(synopsis "Software for engineers and scientists")
(description "This package provides the non-graphical version of the Scilab