aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index ba49edb0c3..f3d5be7aba 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -10113,7 +10113,12 @@ computation is supported via MPI.")
"\"${XDG_STATE_HOME:-$HOME/.local/state}/scilab/"
#$(package-version this-package) "\""))
(("export SCI=")
- "unset LANGUAGE\nexport SCI="))))))))
+ "unset LANGUAGE\nexport SCI="))))
+ (add-after 'rewrap-scilab-cli 'sanity-check
+ (lambda _
+ (setenv "HOME" (getcwd))
+ (invoke (string-append #$output "/bin/scilab-cli")
+ "-e" "\"quit;\"")))))))
(home-page "https://www.scilab.org/")
(synopsis "Software for engineers and scientists")
(description "This package provides the non-graphical version of the Scilab