aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 5f47d5e390..03fa4d2fae 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -2363,8 +2363,9 @@ sharing of scientific data.")
((#:configure-flags flags)
`(cons* "CC=mpicc" "CXX=mpicxx"
"--enable-parallel-tests"
- ;; Shared libraries not supported with parallel IO.
- "--disable-shared" "--with-pic"
+ ;; NetCDF supports both parallel and shared library building
+ ;; See https://docs.unidata.ucar.edu/nug/current/getting_and_building_netcdf.html#build_parallel
+ "--enable-shared" "--with-pic"
,flags))
((#:phases phases '%standard-phases)
`(modify-phases ,phases