aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndré Batista <nandre@riseup.net>2024-09-05 23:17:07 +0000
committerLudovic Courtès <ludo@gnu.org>2024-09-30 20:52:23 +0000
commitbb1480a38d7400ca075516b588849f2c9116f26a (patch)
treef6dd924d6a818f2c32cd67b44fe5cb39359f5a2a
parentf0a1915564c11a8f7188c486ab38ed7d29ea0bb5 (diff)
downloadguix-bb1480a38d7400ca075516b588849f2c9116f26a.tar
guix-bb1480a38d7400ca075516b588849f2c9116f26a.tar.gz
guix-bb1480a38d7400ca075516b588849f2c9116f26a.tar.bz2
guix-bb1480a38d7400ca075516b588849f2c9116f26a.tar.lz
guix-bb1480a38d7400ca075516b588849f2c9116f26a.tar.xz
guix-bb1480a38d7400ca075516b588849f2c9116f26a.tar.zst
guix-bb1480a38d7400ca075516b588849f2c9116f26a.zip
gnu: Add go-gitlab-torproject-org-tpo-anti-censorship-pluggable-transports-webtunnel.
* gnu/packages/golang.scm (go-gitlab-torproject-org-tpo-anti-censorship-pluggable-transports-webtunnel): New variable. Change-Id: I84ef723ea03822bd5abf655914f44fb53fd865e2 Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/golang.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 9f04b8e423..af2acc909e 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2241,6 +2241,31 @@ Go.")
incorporates ideas and concepts from Philipp Winter's ScrambleSuit protocol.")
(license (list license:bsd-2 license:bsd-3))))
+(define-public go-gitlab-torproject-org-tpo-anti-censorship-pluggable-transports-webtunnel
+ (let ((commit "e64b1b3562f3ab50d06141ecd513a21ec74fe8c6")
+ (revision "0"))
+ (package
+ (name "go-gitlab-torproject-org-tpo-anti-censorship-pluggable-transports-webtunnel")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://gitlab.torproject.org/tpo/anti-censorship/pluggable-transports/webtunnel")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0nvd0qp1mdy7w32arnkhghxm5k2g6gy33cxlarxc6vdm4yh6v5nv"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "gitlab.torproject.org/tpo/anti-censorship/pluggable-transports/webtunnel"))
+ (home-page "https://gitlab.torproject.org/tpo/anti-censorship/pluggable-transports/webtunnel")
+ (synopsis "Go WebTunnel Pluggable Transport")
+ (description "WebTunnel is a Go Pluggable Transport that attempts to imitate
+web browsing activities based on HTTP Upgrade (HTTPT).")
+ (license license:bsd-2))))
+
(define-public go-github-com-sevlyar-go-daemon
(package
(name "go-github-com-sevlyar-go-daemon")