aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-20 21:42:56 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-09-30 21:06:32 +0000
commit87bc80efcd0834b03af60aec843f122be5b9ba5a (patch)
tree634638a4a410808ac966d510aa69701bdc923d45
parent49a013a0ede0d8a25bf66d452fd9b5df5409e688 (diff)
downloadguix-87bc80efcd0834b03af60aec843f122be5b9ba5a.tar
guix-87bc80efcd0834b03af60aec843f122be5b9ba5a.tar.gz
guix-87bc80efcd0834b03af60aec843f122be5b9ba5a.tar.bz2
guix-87bc80efcd0834b03af60aec843f122be5b9ba5a.tar.lz
guix-87bc80efcd0834b03af60aec843f122be5b9ba5a.tar.xz
guix-87bc80efcd0834b03af60aec843f122be5b9ba5a.tar.zst
guix-87bc80efcd0834b03af60aec843f122be5b9ba5a.zip
gnu: Add python-pytest-cython.
* gnu/packages/python-check.scm (python-pytest-cython): New variable. Change-Id: I4f223bb0a88db3fd91bb312dfe4558a075ff8bb2
-rw-r--r--gnu/packages/python-check.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 4888b42bc1..382a5453bb 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -1784,6 +1784,44 @@ plain (undecoratored) native coroutine tests.")
"This package provides a shim Pytest plugin to enable a Celery marker.")
(license license:bsd-3)))
+(define-public python-pytest-cython
+ (package
+ (name "python-pytest-cython")
+ (version "0.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-cython" version))
+ (sha256
+ (base32 "0ma496dgmmrpgqd3zk6vin29dgajcplh63yqd8jh2a3ai954fr22"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:test-flags
+ #~(list "tests"
+ ;; FIXME: Failed: nomatch: '*sqr*PASSED*
+ "-k" (string-append
+ "not test_wrap_cpp_ext_module[importlib]"
+ " and not test_wrap_c_ext_module[importlib]"
+ " and not test_cython_ext_module[importlib]"))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'build-extensions
+ (lambda _
+ (with-directory-excursion "tests/example-project"
+ (invoke "python" "setup.py" "build_ext" "--inplace")))))))
+ (native-inputs
+ (list python-nox
+ python-cython-3
+ python-setuptools))
+ (propagated-inputs
+ (list python-pytest-8))
+ (home-page "https://github.com/lgpage/pytest-cython")
+ (synopsis "Cython extension modules testing plugin")
+ (description
+ "This package provides a plugin for testing Cython extension modules.")
+ (license license:expat)))
+
(define-public python-pytest-env
(package
(name "python-pytest-env")