aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-19 14:15:18 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-09-30 21:06:32 +0000
commit49a013a0ede0d8a25bf66d452fd9b5df5409e688 (patch)
tree8241131d5e1a7a7145b1bacf0d58e220166155e9
parentd799c6fee02578f64897d32ca4f28af6b3c7b1b3 (diff)
downloadguix-49a013a0ede0d8a25bf66d452fd9b5df5409e688.tar
guix-49a013a0ede0d8a25bf66d452fd9b5df5409e688.tar.gz
guix-49a013a0ede0d8a25bf66d452fd9b5df5409e688.tar.bz2
guix-49a013a0ede0d8a25bf66d452fd9b5df5409e688.tar.lz
guix-49a013a0ede0d8a25bf66d452fd9b5df5409e688.tar.xz
guix-49a013a0ede0d8a25bf66d452fd9b5df5409e688.tar.zst
guix-49a013a0ede0d8a25bf66d452fd9b5df5409e688.zip
gnu: Add python-ci-watson.
* gnu/packages/astronomy.scm (python-ci-watson): New variable. Change-Id: I0590bdd7c3847d9b5cc80de94e40149c475bd46a
-rw-r--r--gnu/packages/astronomy.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index c7a3ee2668..c6791c8c21 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2809,6 +2809,39 @@ attempting to maintain ISTP compliance
@end itemize")
(license license:expat)))
+(define-public python-ci-watson
+ (package
+ (name "python-ci-watson")
+ (version "0.7.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "ci_watson" version))
+ (sha256
+ (base32 "1qb5iyb053k1711ic93rcm0z344dc6h8vg8fpkbqpg5z6q0v2b0y"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-pypojrect-toml
+ (lambda _
+ (substitute* "setup.cfg"
+ ;; ImportError: Error importing plugin " no:legacypath": No
+ ;; module named ' no:legacypath'
+ (("-p no:legacypath") "")))))))
+ (propagated-inputs
+ (list python-crds
+ python-pytest
+ python-requests))
+ (native-inputs
+ (list python-pytest-astropy-header))
+ (home-page "https://github.com/spacetelescope/ci_watson")
+ (synopsis "Helper functions for STScI software")
+ (description
+ "This package contains a helper functionality to test ROMAN and JWST.")
+ (license license:bsd-3)))
+
(define-public python-cmyt
(package
(name "python-cmyt")