aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFredrik Salomonsson <plattfot@posteo.net>2024-08-26 01:27:24 +0000
committerLudovic Courtès <ludo@gnu.org>2024-10-04 19:26:24 +0000
commit6c132dfce8aa172071637a33ebfc9c38646c1552 (patch)
tree9334272b8e6fce4afacaee6bb9a8eb00fe35ad81
parented0d985385cc4c45c9da2cc0886e454d261f3720 (diff)
downloadguix-6c132dfce8aa172071637a33ebfc9c38646c1552.tar
guix-6c132dfce8aa172071637a33ebfc9c38646c1552.tar.gz
guix-6c132dfce8aa172071637a33ebfc9c38646c1552.tar.bz2
guix-6c132dfce8aa172071637a33ebfc9c38646c1552.tar.lz
guix-6c132dfce8aa172071637a33ebfc9c38646c1552.tar.xz
guix-6c132dfce8aa172071637a33ebfc9c38646c1552.tar.zst
guix-6c132dfce8aa172071637a33ebfc9c38646c1552.zip
gnu: guix-simplyblack-sddm-theme: Update to 0.2.
* gnu/packages/display-managers.scm (guix-simplyblack-sddm-theme): Update to 0.2. Change-Id: I2332f51da9c9a41bdd9a55af2a5d2f3336e6c586 Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/display-managers.scm45
1 files changed, 26 insertions, 19 deletions
diff --git a/gnu/packages/display-managers.scm b/gnu/packages/display-managers.scm
index a98c90d575..c00fb48a2a 100644
--- a/gnu/packages/display-managers.scm
+++ b/gnu/packages/display-managers.scm
@@ -7,7 +7,7 @@
;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 L p R n d n <guix@lprndn.info>
-;;; Copyright © 2020 Fredrik Salomonsson <plattfot@gmail.com>
+;;; Copyright © 2020, 2024 Fredrik Salomonsson <plattfot@posteo.net>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2021 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2021-2023 Efraim Flashner <efraim@flashner.co.il>
@@ -222,26 +222,33 @@ background.")
(define-public guix-simplyblack-sddm-theme
(package
(name "guix-simplyblack-sddm-theme")
- (version "0.1")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/plattfot/guix-simplyblack-sddm")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1fwny6b0xpjs8ad2b16pyxd27gf0sr0nillmhc2h5k0q7dva21vi"))))
+ (version "0.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/plattfot/guix-simplyblack-sddm")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "09vb9b0pmyhj6fh0b6by59bykszbkdayhz678pnb4pyrdmlvv1am"))))
(build-system trivial-build-system)
(arguments
- `(#:modules ((guix build utils))
- #:builder
- (begin
- (use-modules (guix build utils))
- (let* ((out (assoc-ref %outputs "out"))
- (sddm-themes (string-append out "/share/sddm/themes")))
- (mkdir-p sddm-themes)
- (copy-recursively (assoc-ref %build-inputs "source")
- (string-append sddm-themes "/guix-simplyblack-sddm"))))))
+ `(#:modules ((guix build utils)
+ (srfi srfi-26))
+ #:builder (begin
+ (use-modules (guix build utils)
+ (srfi srfi-26))
+ (let* ((out (assoc-ref %outputs "out"))
+ (themes-dir (string-append out
+ "/share/sddm/themes/guix-simplyblack-sddm/")))
+ (mkdir-p themes-dir)
+ (copy-recursively (assoc-ref %build-inputs "source")
+ themes-dir)
+ (substitute* (map (cut string-append themes-dir <>)
+ '("Main.qml" "theme.conf"))
+ (("file:")
+ themes-dir))))))
(home-page "https://github.com/plattfot/guix-simplyblack-sddm")
(synopsis "Guix based theme for SDDM")
(description