aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-10-02 21:48:56 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-10-02 21:58:39 +0000
commit3abe0134be94170afda0085a6feea6436eda934c (patch)
tree2b04c658edc71d69724bb594f423b0171b896548
parent37076a20f9b8eb17566dfaaef7858205b2e71545 (diff)
downloadguix-3abe0134be94170afda0085a6feea6436eda934c.tar
guix-3abe0134be94170afda0085a6feea6436eda934c.tar.gz
guix-3abe0134be94170afda0085a6feea6436eda934c.tar.bz2
guix-3abe0134be94170afda0085a6feea6436eda934c.tar.lz
guix-3abe0134be94170afda0085a6feea6436eda934c.tar.xz
guix-3abe0134be94170afda0085a6feea6436eda934c.tar.zst
guix-3abe0134be94170afda0085a6feea6436eda934c.zip
gnu: python-pynsee: Update to 0.1.8.
* gnu/packages/python-science.scm (python-pynsee): Update to 0.1.8. [propagated-inputs]: Add python-openpyxl, python-platformdirs, python-pyarrow, and python-xlrd. [native-inputs]: Add python-setuptools and python-wheel. Change-Id: Ibb9ec7b979b7e27d2c2a48e2bf27dfcddc79200d
-rw-r--r--gnu/packages/python-science.scm26
1 files changed, 17 insertions, 9 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index d6c93b8ccb..7c8d41cdc2 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -3479,22 +3479,30 @@ and from numpy arrays.")
(define-public python-pynsee
(package
(name "python-pynsee")
- (version "0.1.7")
+ (version "0.1.8")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pynsee" version))
(sha256
- (base32 "0wd1xhkjpll8mzrrhnqxrand32p338j2zfw3h1gxacf31iwxhips"))))
+ (base32 "1w084ynwdd9f4wpcnakqc0nxcbj9gr8vppv4rd258i3dp1qq4sw5"))))
(build-system pyproject-build-system)
(arguments (list #:tests? #f)) ; XXX: Tests require network access.
- (propagated-inputs (list python-appdirs
- python-pandas
- python-requests
- python-shapely
- python-tqdm
- python-unidecode
- python-urllib3))
+ (native-inputs
+ (list python-setuptools
+ python-wheel))
+ (propagated-inputs
+ (list python-appdirs
+ python-openpyxl
+ python-pandas
+ python-platformdirs
+ python-pyarrow
+ python-requests
+ python-shapely
+ python-tqdm
+ python-unidecode
+ python-urllib3
+ python-xlrd))
(home-page "https://pynsee.readthedocs.io")
(synopsis
"Tools to Easily Search and Download French Data From INSEE and IGN APIs")