aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-04-16 12:34:01 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-10-02 21:58:39 +0000
commit37076a20f9b8eb17566dfaaef7858205b2e71545 (patch)
tree15e9654e326bcdc79bb44481a55653b8abb6e0b2
parent44ea0b37b44a0927d908a348329b03a5301fb109 (diff)
downloadguix-37076a20f9b8eb17566dfaaef7858205b2e71545.tar
guix-37076a20f9b8eb17566dfaaef7858205b2e71545.tar.gz
guix-37076a20f9b8eb17566dfaaef7858205b2e71545.tar.bz2
guix-37076a20f9b8eb17566dfaaef7858205b2e71545.tar.lz
guix-37076a20f9b8eb17566dfaaef7858205b2e71545.tar.xz
guix-37076a20f9b8eb17566dfaaef7858205b2e71545.tar.zst
guix-37076a20f9b8eb17566dfaaef7858205b2e71545.zip
gnu: Add python-pynsee.
* gnu/packages/python-science.scm (python-pynsee): New variable. Change-Id: I4e93d26ad4b6be238b0e4cce82ea77030caf6e02 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
-rw-r--r--gnu/packages/python-science.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index fe146717ce..d6c93b8ccb 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -25,6 +25,7 @@
;;; Copyright © 2023, 2024 Troy Figiel <troy@troyfigiel.com>
;;; Copyright © 2024 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2024 Marco Baggio <marco.baggio@mdc-berlin.de>
+;;; Copyright © 2024 Nicolas Graves <ngraves@ngraves.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3475,6 +3476,37 @@ visualization and image processing involving N-dimensional raster data) into
and from numpy arrays.")
(license license:expat)))
+(define-public python-pynsee
+ (package
+ (name "python-pynsee")
+ (version "0.1.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pynsee" version))
+ (sha256
+ (base32 "0wd1xhkjpll8mzrrhnqxrand32p338j2zfw3h1gxacf31iwxhips"))))
+ (build-system pyproject-build-system)
+ (arguments (list #:tests? #f)) ; XXX: Tests require network access.
+ (propagated-inputs (list python-appdirs
+ python-pandas
+ python-requests
+ python-shapely
+ python-tqdm
+ python-unidecode
+ python-urllib3))
+ (home-page "https://pynsee.readthedocs.io")
+ (synopsis
+ "Tools to Easily Search and Download French Data From INSEE and IGN APIs")
+ (description
+ "This package provides tools to easily search and download French data
+from INSEE and IGN APIs. This data includes more than 150 000 macroeconomic
+series, a dozen datasets of local french data, numerous sources available on
+@url{insee.fr}, geographical limits of administrative areas taken from IGN as
+well as key metadata and SIRENE database containing data on all French
+compagnies.")
+ (license license:expat)))
+
(define-public python-libneuroml
(package
(name "python-libneuroml")