aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 5723655005..ba49edb0c3 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -9966,6 +9966,7 @@ computation is supported via MPI.")
autoconf-archive
automake
bison
+ coreutils-minimal
eigen
flex
gfortran
@@ -10073,6 +10074,10 @@ computation is supported via MPI.")
(("PROGNAME.*") "\n")))))
(add-before 'build 'pre-build
(lambda* (#:key inputs #:allow-other-keys)
+ ;; Fix scilab script.
+ (substitute* "bin/scilab"
+ (("/bin/ls")
+ (search-input-file inputs "bin/ls")))
;; Fix core.start.
(substitute* "modules/core/etc/core.start"
(("'SCI/modules")