aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/maths.scm4
-rw-r--r--gnu/packages/patches/scilab-tbx_build_help.patch33
2 files changed, 17 insertions, 20 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 2106d73ef1..40b192c8b6 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -9891,7 +9891,7 @@ computation is supported via MPI.")
(define-public scilab
(package
(name "scilab")
- (version "2024.0.0")
+ (version "2024.1.0")
(source
(origin
(method git-fetch)
@@ -9901,7 +9901,7 @@ computation is supported via MPI.")
(file-name (git-file-name name version))
(sha256
(base32
- "08nyfli3x7gd396ffd1a8zn9fj3gm6a8yw0ggm547c09sp2rgvl7"))
+ "1qk0pf1cwcvdqjza9xqkynd90ywq0yh421bz59w5zjzbs40ijnrx"))
(patches (search-patches "scilab-better-compiler-detection.patch"
"scilab-tbx_build_help.patch"))
(modules '((guix build utils)
diff --git a/gnu/packages/patches/scilab-tbx_build_help.patch b/gnu/packages/patches/scilab-tbx_build_help.patch
index d2a9b41357..34dbe7dfa4 100644
--- a/gnu/packages/patches/scilab-tbx_build_help.patch
+++ b/gnu/packages/patches/scilab-tbx_build_help.patch
@@ -1,38 +1,35 @@
-From c59d78c5a5c8c187450f157cf7f8480455e8e6a2 Mon Sep 17 00:00:00 2001
+From 24a9bc240729b7630e20a7b83b75f086024ae03d Mon Sep 17 00:00:00 2001
From: Nicolas Graves <ngraves@ngraves.fr>
-Date: Wed, 3 Apr 2024 03:32:23 +0200
+Date: Wed, 21 Aug 2024 15:42:35 +0200
Subject: [PATCH] scilab: tbx_build_help: Allow for some flexibility under
-nwni.
upstream reference: https://gitlab.com/scilab/scilab/-/merge_requests/818
-
---
- .../modules_manager/macros/tbx_build_help.sci | 12 ++++++------
- 1 file changed, 6 insertions(+), 6 deletions(-)
+ scilab/modules/modules_manager/macros/tbx_build_help.sci | 5 +++--
+ 1 file changed, 3 insertions(+), 2 deletions(-)
diff --git a/scilab/modules/modules_manager/macros/tbx_build_help.sci b/scilab/modules/modules_manager/macros/tbx_build_help.sci
-index 7862e33a868..5593ee3dc04 100644
+index ab06b3fa8dc..cbb1b4cadf8 100644
--- a/scilab/modules/modules_manager/macros/tbx_build_help.sci
+++ b/scilab/modules/modules_manager/macros/tbx_build_help.sci
-@@ -58,12 +58,12 @@ function tbx_build_help(moduletitle, path)
+@@ -57,8 +57,8 @@ function tbx_build_help(moduletitle, path)
// Check scilab mode
if and(getscilabmode() <> ["STD" "NW"]) then
- error(msprintf(gettext("%s: documentation cannot be built in this scilab mode: %s.\n"),"tbx_build_help",getscilabmode()));
+- end
+ msprintf(gettext("%s: documentation cannot be built in this scilab mode: %s.\n"),"tbx_build_help",getscilabmode());
+ else
-+ directory_language = basename(path);
-+ default_language = "en_US"
-+
-+ xmltojar(path, moduletitle, directory_language, default_language);
- end
-- directory_language = basename(path);
-- default_language = "en_US"
--
-- xmltojar(path, moduletitle, directory_language, default_language);
--
+ directory_language = basename(path);
+ default_language = "en_US"
+@@ -89,4 +89,5 @@ function tbx_build_help(moduletitle, path)
+ warning(_(".start file was not found, build of help pages using <scilab:image> tag may failed."));
+ xmltojar(path, moduletitle, directory_language, default_language);
+ end
++ end
endfunction
--
-2.41.0
+2.45.2