aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Eure <ian@retrospec.tv>2024-10-05 16:19:10 +0000
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-10-08 07:34:38 +0000
commitdaaba6ac16e287167d612d5d4660735a7058b507 (patch)
tree805032963ade36ba16e069654b2cf9eaca86e48e
parenta950a89d2f7e6fed8c0a209e5c75f6605e7b469b (diff)
downloadguix-daaba6ac16e287167d612d5d4660735a7058b507.tar
guix-daaba6ac16e287167d612d5d4660735a7058b507.tar.gz
guix-daaba6ac16e287167d612d5d4660735a7058b507.tar.bz2
guix-daaba6ac16e287167d612d5d4660735a7058b507.tar.lz
guix-daaba6ac16e287167d612d5d4660735a7058b507.tar.xz
guix-daaba6ac16e287167d612d5d4660735a7058b507.tar.zst
guix-daaba6ac16e287167d612d5d4660735a7058b507.zip
gnu: librewolf: Fix broken context menu.
This patch fixes a reported bug where context (right-click) menus contain many duplicate and incorrect entries. * gnu/packages/librewolf.scm (librewolf) [phases] <neuter-genai>: Reinstate the genai browser component. Change-Id: I288545ce80b9a7e854edfc26a7ffe43433303458
-rw-r--r--gnu/packages/librewolf.scm5
1 files changed, 1 insertions, 4 deletions
diff --git a/gnu/packages/librewolf.scm b/gnu/packages/librewolf.scm
index 6fd0aa51f1..32b6d13d54 100644
--- a/gnu/packages/librewolf.scm
+++ b/gnu/packages/librewolf.scm
@@ -212,7 +212,7 @@
;; Update this id with every update to its release date.
;; It's used for cache validation and therefore can lead to strange bugs.
;; ex: date '+%Y%m%d%H%M%S'
-(define %librewolf-build-id "20240922110507")
+(define %librewolf-build-id "20241003201141")
(define-public librewolf
(package
@@ -324,9 +324,6 @@
libavcodec)))))
(add-after 'unpack 'neuter-genai
(lambda* _
- ;; Don't compile the code in.
- (substitute* "browser/components/moz.build"
- (("\"genai\",") ""))
;; Lock the preferences so they can't be enabled.
(substitute* "lw/librewolf.cfg"
(("defaultPref\\(\"browser\\.ml\\.")