aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndy Tai <atai@atai.org>2024-09-25 02:26:25 +0000
committerLudovic Courtès <ludo@gnu.org>2024-10-04 15:28:51 +0000
commitc32dcfd09c630ccd21cf248e2ebf49dec157101d (patch)
tree704b29e656cdc8e0bd67e15e98bab91d7ab382b0
parent51868735f343c487d3a1a66bc3ef49926749e424 (diff)
downloadguix-c32dcfd09c630ccd21cf248e2ebf49dec157101d.tar
guix-c32dcfd09c630ccd21cf248e2ebf49dec157101d.tar.gz
guix-c32dcfd09c630ccd21cf248e2ebf49dec157101d.tar.bz2
guix-c32dcfd09c630ccd21cf248e2ebf49dec157101d.tar.lz
guix-c32dcfd09c630ccd21cf248e2ebf49dec157101d.tar.xz
guix-c32dcfd09c630ccd21cf248e2ebf49dec157101d.tar.zst
guix-c32dcfd09c630ccd21cf248e2ebf49dec157101d.zip
gnu: ddd: Update to 3.4.1.
* gnu/packages/debug.scm (ddd): Update to 3.4.1. [source](origin): Add new patch to fix build. [arguments]<#:configure-flags>: Add explicit flag fir freetype include path. [native-inputs]: Add bison, flex and perl. [inputs]: Add freetype, libxaw, and libxft. * gnu/packages/patches/ddd-build.patch: New file. * gnu/local.mk: Register new file. Change-Id: Ic305cc0c7e15d0f0565f2adde514a43497e11f98 Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/debug.scm18
-rw-r--r--gnu/packages/patches/ddd-build.patch24
3 files changed, 35 insertions, 8 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 49660d4b3e..2adf196a87 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1133,6 +1133,7 @@ dist_patch_DATA = \
%D%/packages/patches/dbus-c++-gcc-compat.patch \
%D%/packages/patches/dbus-c++-threading-mutex.patch \
%D%/packages/patches/dbxfs-remove-sentry-sdk.patch \
+ %D%/packages/patches/ddd-build.patch \
%D%/packages/patches/debops-constants-for-external-program-names.patch \
%D%/packages/patches/debops-debops-defaults-fall-back-to-less.patch \
%D%/packages/patches/dee-vapi.patch \
diff --git a/gnu/packages/debug.scm b/gnu/packages/debug.scm
index b8ddafaba6..526d5d408a 100644
--- a/gnu/packages/debug.scm
+++ b/gnu/packages/debug.scm
@@ -52,6 +52,7 @@
#:use-module (gnu packages code)
#:use-module (gnu packages compression)
#:use-module (gnu packages flex)
+ #:use-module (gnu packages fontutils)
#:use-module (gnu packages gcc)
#:use-module (gnu packages gdb)
#:use-module (gnu packages glib)
@@ -1006,23 +1007,24 @@ engineering.")
(define-public ddd
(package
(name "ddd")
- (version "3.4.0")
+ (version "3.4.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/ddd/ddd-" version ".tar.gz"))
+ (patches (search-patches "ddd-build.patch"))
(sha256
(base32
- "03sqsfiri5p130cmmzh2wikg0gisql496rvdhr1qaidh1f5bqk2x"))))
+ "12gfyh139rim49m56lxm36ckdyiiz4n3la3y6ik1aqgrqfk1fxdq"))))
(build-system gnu-build-system)
(arguments
- (list #:tests? #f ;tests require manual intervention
- ;; Avoid "friend declaration specifies default arguments and isn’t
- ;; a definition" errors.
- #:configure-flags #~(list "CXXFLAGS=-fpermissive")))
+ (list #:tests? #f ;tests require manual intervention
+ #:configure-flags
+ #~(list (string-append "--with-freetype-includes="
+ #$(this-package-input "freetype") "/include/freetype2"))))
(native-inputs
- (list pkg-config))
+ (list pkg-config bison flex perl))
(inputs
- (list motif ncurses gdb))
+ (list libxaw libxft freetype motif ncurses gdb))
(synopsis "Graphical front-end for GDB and other debuggers")
(description "GNU DDD, the Data Display Debugger, is a graphical front-end
for command-line debuggers. Many back-end debuggers are supported, notably
diff --git a/gnu/packages/patches/ddd-build.patch b/gnu/packages/patches/ddd-build.patch
new file mode 100644
index 0000000000..5db2833504
--- /dev/null
+++ b/gnu/packages/patches/ddd-build.patch
@@ -0,0 +1,24 @@
+Add missing '-I' flag.
+
+--- old/ddd/Makefile.am (revision 7508)
++++ new/ddd/Makefile.am (working copy)
+@@ -655,7 +655,7 @@
+ LIBXFT = @XFT_LIBS@ -lfontconfig
+
+ # Freetype2 headers
+-XFTINCLUDE = @XFT_INCLUDE@
++XFTINCLUDE = -I@XFT_INCLUDE@
+
+ # X Miscellaneous Utilities needed for Athena and Motif >= 2.0 (lXmu)
+ LIBXMU = @XMU_LIBS@
+--- old/ddd/Makefile.in (revision 7508)
++++ new/ddd/Makefile.in (working copy)
+@@ -1307,7 +1307,7 @@
+ LIBXFT = @XFT_LIBS@ -lfontconfig
+
+ # Freetype2 headers
+-XFTINCLUDE = @XFT_INCLUDE@
++XFTINCLUDE = -I@XFT_INCLUDE@
+
+ # X Miscellaneous Utilities needed for Athena and Motif >= 2.0 (lXmu)
+ LIBXMU = @XMU_LIBS@