aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-18 14:19:08 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-09-30 21:06:31 +0000
commit7bdbaf040279903ce5ef55a601e9f57dede835f4 (patch)
tree5338441ae86f889cdd1b4d560efefe109455db40
parent59340b4bfbd0d4b78b7c79a4b5b03ea3a7f3ddc2 (diff)
downloadguix-7bdbaf040279903ce5ef55a601e9f57dede835f4.tar
guix-7bdbaf040279903ce5ef55a601e9f57dede835f4.tar.gz
guix-7bdbaf040279903ce5ef55a601e9f57dede835f4.tar.bz2
guix-7bdbaf040279903ce5ef55a601e9f57dede835f4.tar.lz
guix-7bdbaf040279903ce5ef55a601e9f57dede835f4.tar.xz
guix-7bdbaf040279903ce5ef55a601e9f57dede835f4.tar.zst
guix-7bdbaf040279903ce5ef55a601e9f57dede835f4.zip
gnu: python-sunpy: Update to 6.0.2.
* gnu/packages/astronomy.scm (python-sunpy): Update to 6.0.2. [arguments]: <#:test-flags>: Enable more tests as the issue is resolved. Change-Id: Ib7506442d8c1447425a4ca24a7ffeb5c1cd9fa6a
-rw-r--r--gnu/packages/astronomy.scm17
1 files changed, 5 insertions, 12 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 1dd8efef0c..c8d4cbfef3 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -3587,27 +3587,20 @@ orbits described in TLE files.")
(define-public python-sunpy
(package
(name "python-sunpy")
- (version "6.0.1")
+ (version "6.0.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "sunpy" version))
(sha256
- (base32 "1yp7x26fzxs66bfvzaim8ns5q6514l66mbz5gabhlxb9pp8i6i85"))))
+ (base32 "0mzmq2ncqgq61c1maxwynrmzcyiafnlil5mx4vhy2cvdyacm8yc9"))))
(build-system pyproject-build-system)
(arguments
(list
#:test-flags
- #~(list
- "--numprocesses" "auto"
- "-k" (string-append
- ;; XXX: Failed: DID NOT RAISE <class 'ModuleNotFoundError'>
- ;; It struggles to find python-opencsv package info with
- ;; 'importlib.metadata'
- "not test_main_nonexisting_module"
- " and not test_main_stdlib_module")
- ;; Requries SpicePy not packed in Guix yet.
- "--ignore=sunpy/coordinates/tests/test_spice.py")
+ #~(list "--numprocesses" "auto"
+ ;; Requries SpicePy not packed in Guix yet.
+ "--ignore=sunpy/coordinates/tests/test_spice.py")
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'relax-requirements