aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorkiasoc5 <kiasoc5@disroot.org>2024-08-27 20:44:45 +0000
committerLudovic Courtès <ludo@gnu.org>2024-10-04 19:29:40 +0000
commit73ec844389e91cb0f5a2647070516fc8d19d8730 (patch)
tree0f3e0631014a080e2ee5978963dbe99f0c5af833
parent5d2d395477165320703a01c2a653b11f69fea595 (diff)
downloadguix-73ec844389e91cb0f5a2647070516fc8d19d8730.tar
guix-73ec844389e91cb0f5a2647070516fc8d19d8730.tar.gz
guix-73ec844389e91cb0f5a2647070516fc8d19d8730.tar.bz2
guix-73ec844389e91cb0f5a2647070516fc8d19d8730.tar.lz
guix-73ec844389e91cb0f5a2647070516fc8d19d8730.tar.xz
guix-73ec844389e91cb0f5a2647070516fc8d19d8730.tar.zst
guix-73ec844389e91cb0f5a2647070516fc8d19d8730.zip
gnu: gpodder: Update to 3.11.4.
* gnu/packages/gpodder.scm (gpodder): Update to 3.11.4. [inputs]: Replace youtube-dl with yt-dlp. [arguments]: Use G-expressions. Use #$output and search-input-file instead of assoc-ref. Remove trailing #t from phases. Change-Id: Ic5c07f63e1e5e419857ead2d58cd273660e0cad5 Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/gpodder.scm74
1 files changed, 35 insertions, 39 deletions
diff --git a/gnu/packages/gpodder.scm b/gnu/packages/gpodder.scm
index 1073af0f3b..c3e1c9b496 100644
--- a/gnu/packages/gpodder.scm
+++ b/gnu/packages/gpodder.scm
@@ -22,6 +22,7 @@
(define-module (gnu packages gpodder)
#:use-module (guix download)
#:use-module (guix git-download)
+ #:use-module (guix gexp)
#:use-module (guix packages)
#:use-module (guix utils)
#:use-module ((guix licenses) #:prefix license:)
@@ -50,7 +51,7 @@
(define-public gpodder
(package
(name "gpodder")
- (version "3.11.1")
+ (version "3.11.4")
(source
(origin
(method git-fetch)
@@ -58,7 +59,7 @@
(url "https://github.com/gpodder/gpodder")
(commit version)))
(sha256
- (base32 "121cb8qz4rp6602lpbi6m2vqx3ar1cw2s4z4r7nr5qaxb0q3gk9n"))
+ (base32 "1zmp7kkldb59fx1y6k4mkff8ngmyb9pflcd3yqb28m9wb9bp4j4h"))
(file-name (git-file-name name version))
(patches (search-patches "gpodder-disable-updater.patch"))))
(build-system python-build-system)
@@ -81,47 +82,42 @@
python-mutagen
python-mygpoclient
python-podcastparser
- youtube-dl
+ yt-dlp
xdg-utils))
(arguments
- '(#:phases
- (modify-phases %standard-phases
- ;; Avoid needing xdg-utils as a propagated input.
- (add-after 'unpack 'patch-xdg-open
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((xdg-utils (assoc-ref inputs "xdg-utils")))
- (substitute* "src/gpodder/util.py"
- (("xdg-open") (string-append xdg-utils "/bin/xdg-open")))
- #t)))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "make" "unittest"))))
- ;; 'msgmerge' introduces non-determinism by resetting the
- ;; POT-Creation-Date in .po files.
- (add-before 'install 'do-not-run-msgmerge
- (lambda _
- (substitute* "makefile"
- (("msgmerge") "true"))
- #t))
- (add-before 'install 'make-po-files-writable
- (lambda _
- (for-each
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; Avoid needing xdg-utils as a propagated input.
+ (add-after 'unpack 'patch-xdg-open
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "src/gpodder/util.py"
+ (("xdg-open") (search-input-file inputs "bin/xdg-open")))))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "make" "unittest"))))
+ ;; 'msgmerge' introduces non-determinism by resetting the
+ ;; POT-Creation-Date in .po files.
+ (add-before 'install 'do-not-run-msgmerge
+ (lambda _
+ (substitute* "makefile"
+ (("msgmerge") "true"))))
+ (add-before 'install 'make-po-files-writable
+ (lambda _
+ (for-each
(lambda (f)
(chmod f #o664))
- (find-files "po"))
- #t))
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (setenv "PREFIX" (assoc-ref outputs "out"))
- (invoke "make" "install")))
- (add-after 'install 'wrap-gpodder
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out"))
- (gi-typelib-path (getenv "GI_TYPELIB_PATH")))
- (wrap-program (string-append out "/bin/gpodder")
- `("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path)))
- #t))))))
+ (find-files "po"))))
+ (replace 'install
+ (lambda _
+ (setenv "PREFIX" #$output)
+ (invoke "make" "install")))
+ (add-after 'install 'wrap-gpodder
+ (lambda _
+ (let ((gi-typelib-path (getenv "GI_TYPELIB_PATH")))
+ (wrap-program (string-append #$output "/bin/gpodder")
+ `("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path)))))))))
(home-page "https://gpodder.github.io")
(synopsis "Simple podcast client")
(description "gPodder is a podcatcher, i.e. an application that allows