aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-10-04 12:18:52 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-10-04 12:27:38 +0000
commit725e57a56a677c9c80b20d074d27106b757764af (patch)
tree6ba55753a2b0f39d03098e1083a59497f32d7934
parent84339e1fb5db1596ee751cc704bfc4dd9d3ee428 (diff)
downloadguix-725e57a56a677c9c80b20d074d27106b757764af.tar
guix-725e57a56a677c9c80b20d074d27106b757764af.tar.gz
guix-725e57a56a677c9c80b20d074d27106b757764af.tar.bz2
guix-725e57a56a677c9c80b20d074d27106b757764af.tar.lz
guix-725e57a56a677c9c80b20d074d27106b757764af.tar.xz
guix-725e57a56a677c9c80b20d074d27106b757764af.tar.zst
guix-725e57a56a677c9c80b20d074d27106b757764af.zip
gnu: python-pypandoc: Adjust package style, fix build.
* gnu/packages/python-xyz.scm (python-pypandoc): Use G-expressions, shift order of entries, remove labels from inputs. [build-system]: Swap to pyproject-build-system. [native-inputs]: Add python-poetry-core, texlive-etoolbox. Change-Id: Ib4eac5fde9d56fffd7bd18a11cf653d05d5ff45b
-rw-r--r--gnu/packages/python-xyz.scm30
1 files changed, 16 insertions, 14 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index db9bd2198d..ac3e224d1d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -32413,23 +32413,25 @@ By default it uses the open Python vulnerability database Safety DB.")
(sha256
(base32
"0l6a8ngzpx363q2jskxxkx6psfhqrvc4js80dmn16r3vw6m2cb40"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'disable-tests
+ (lambda _
+ ;; Disable test requiring network access
+ (substitute* "tests.py"
+ (("test_basic_conversion_from_http_url")
+ "skip_test_basic_conversion_from_http_url")))))))
+ (native-inputs
+ (list python-poetry-core
+ (texlive-updmap.cfg
+ (list texlive-etoolbox texlive-lm texlive-xcolor))))
(inputs
(list pandoc python-pandocfilters))
(propagated-inputs
- `(("wheel" ,python-wheel)))
- (native-inputs
- `(("texlive" ,(texlive-updmap.cfg (list texlive-lm texlive-xcolor)))))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'check 'disable-tests
- (lambda _
- ;; Disable test requiring network access
- (substitute* "tests.py"
- (("test_basic_conversion_from_http_url")
- "skip_test_basic_conversion_from_http_url"))
- #t)))))
+ (list python-wheel))
(home-page "https://github.com/bebraw/pypandoc")
(synopsis "Python wrapper for pandoc")
(description "pypandoc is a thin Python wrapper around pandoc