aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Faiz via Guix-patches via <guix-patches@gnu.org>2024-08-06 13:07:40 +0000
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-10-05 18:36:50 +0000
commit37dede4c4d8c25a786f2a2e2a17ba54b4ba6283f (patch)
tree48b823d73e7c38acc771808df69e7e73f55c026d
parent002df8abd2f4d7c5d23febb1459b77c880345ca7 (diff)
downloadguix-37dede4c4d8c25a786f2a2e2a17ba54b4ba6283f.tar
guix-37dede4c4d8c25a786f2a2e2a17ba54b4ba6283f.tar.gz
guix-37dede4c4d8c25a786f2a2e2a17ba54b4ba6283f.tar.bz2
guix-37dede4c4d8c25a786f2a2e2a17ba54b4ba6283f.tar.lz
guix-37dede4c4d8c25a786f2a2e2a17ba54b4ba6283f.tar.xz
guix-37dede4c4d8c25a786f2a2e2a17ba54b4ba6283f.tar.zst
guix-37dede4c4d8c25a786f2a2e2a17ba54b4ba6283f.zip
gnu: libtorrent-rasterbar: Update to 2.0.10.
* gnu/packages/bittorrent.scm (libtorrent-rasterbar): Update to 2.0.10. [source]<snippet>: Remove test/test_copy_file.cpp patch since it's resolved. [native-inputs]: Remove no longer needed file (v2_empty_file.torrent). [arguments]<#:phases>: Remove copy-v2_empty_file.torrent phase. Signed-off-by: Zheng Junjie <zhengjunjie@iscas.ac.cn> Change-Id: I12e50041cfa141282a2874bf94545bc57ea735ae
-rw-r--r--gnu/packages/bittorrent.scm28
1 files changed, 3 insertions, 25 deletions
diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index b1ab418abb..31c0250916 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -419,16 +419,10 @@ and will take advantage of multiple processor cores where possible.")
(license (list l:public-domain ; sha1.*, used to build without OpenSSL
l:gpl2+)))) ; with permission to link with OpenSSL
-(define %v2_empty_file.torrent
- (origin (method url-fetch)
- (uri "https://github.com/arvidn/libtorrent/raw/v2.0.9/test/test_torrents/v2_empty_file.torrent")
- (sha256
- (base32 "1hydgf0m9193hy9010wl0wrbz4k4cgrqg70jakx68pgi79jcqnrn"))))
-
(define-public libtorrent-rasterbar
(package
(name "libtorrent-rasterbar")
- (version "2.0.9")
+ (version "2.0.10")
(source
(origin
(method url-fetch)
@@ -437,14 +431,7 @@ and will take advantage of multiple processor cores where possible.")
"releases/download/v" version "/"
"libtorrent-rasterbar-" version ".tar.gz"))
(sha256
- (base32 "13kry578ifzz4m2f291bbd7v5v9zsi8y3mf38146cnqw0sv95kch"))
- ;; https://github.com/arvidn/libtorrent/issues/7566
- ;; Remove when resolved. I would hope this to be fixed in 2.0.10.
- (modules '((guix build utils)))
- (snippet
- #~(substitute* "test/test_copy_file.cpp"
- (("EXT4_SUPER_MAGIC, EXT3_SUPER_MAGIC, XFS_SUPER_MAGIC" all)
- (string-append all ", TMPFS_MAGIC\n"))))))
+ (base32 "0pc8rbcp7njbx8m02z47pcbbwcp5cjggbgq4sfjc19dc3n65p4zw"))))
(build-system cmake-build-system)
(arguments
`(#:configure-flags '("-Dpython-bindings=ON"
@@ -453,14 +440,6 @@ and will take advantage of multiple processor cores where possible.")
#:parallel-tests? #f
#:phases
(modify-phases %standard-phases
- ;; https://github.com/arvidn/libtorrent/issues/7567
- ;; Remove when resolved. I would hope this to be fixed in 2.0.10.
- ;; Do not forget to remove the %v2_empty_file.torrent variable.
- (add-before 'configure 'copy-v2_empty_file.torrent
- (lambda* (#:key native-inputs inputs #:allow-other-keys)
- (copy-file (assoc-ref (or native-inputs inputs)
- "%v2_empty_file.torrent")
- "test/test_torrents/v2_empty_file.torrent")))
(replace 'check
(lambda* (#:key tests? parallel-tests? #:allow-other-keys)
(let* ((disabled-tests
@@ -503,8 +482,7 @@ and will take advantage of multiple processor cores where possible.")
(inputs (list boost openssl))
(native-inputs `(("libfaketime" ,libfaketime)
("python-wrapper" ,python-wrapper)
- ("pkg-config" ,pkg-config)
- ("%v2_empty_file.torrent" ,%v2_empty_file.torrent)))
+ ("pkg-config" ,pkg-config)))
(home-page "https://www.libtorrent.org/")
(synopsis "Feature-complete BitTorrent implementation")
(description