aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRomain GARBAGE <romain.garbage@inria.fr>2024-10-02 15:40:00 +0000
committerLudovic Courtès <ludo@gnu.org>2024-10-04 15:23:13 +0000
commit26d1b6b3c9a7322bbdbb01f39dbdeff43c863595 (patch)
tree08ad0536e399f466befb6d3f8479b70966996f29
parented21dd9f8455ae1cb4598b50fcb1cfab36169d2d (diff)
downloadguix-26d1b6b3c9a7322bbdbb01f39dbdeff43c863595.tar
guix-26d1b6b3c9a7322bbdbb01f39dbdeff43c863595.tar.gz
guix-26d1b6b3c9a7322bbdbb01f39dbdeff43c863595.tar.bz2
guix-26d1b6b3c9a7322bbdbb01f39dbdeff43c863595.tar.lz
guix-26d1b6b3c9a7322bbdbb01f39dbdeff43c863595.tar.xz
guix-26d1b6b3c9a7322bbdbb01f39dbdeff43c863595.tar.zst
guix-26d1b6b3c9a7322bbdbb01f39dbdeff43c863595.zip
gnu: Add pnetcdf.
* gnu/packages/maths.scm (pnetcdf): New variable. Change-Id: I419161be82cd45585187abfd1e63a23feac73d59 Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/maths.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 03fa4d2fae..51812c5a0d 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -2350,6 +2350,37 @@ Together, the interface, library, and format support the creation, access, and
sharing of scientific data.")
(license (license:x11-style "file://COPYRIGHT"))))
+(define-public pnetcdf
+ (package
+ (name "pnetcdf")
+ (version "1.13.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://parallel-netcdf.github.io/Release/pnetcdf-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "14f4nbcnw80y59cl0kjpxqqfaxzzd62kixnhb6ihp6aigb3z385b"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:configure-flags
+ #~(list "--enable-shared"
+ (string-append "--with-mpi=" #$(this-package-input "openmpi")))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'build 'mpi-setup
+ #$%openmpi-setup))))
+ (inputs (list openmpi))
+ (native-inputs (list m4))
+ (home-page "https://parallel-netcdf.github.io/")
+ (synopsis "Parallel I/O Library for NetCDF File Access")
+ (description "PnetCDF is a high-performance parallel I/O library for accessing
+Unidata's NetCDF, files in classic formats, specifically the formats of CDF-1, 2, and
+5.")
+ (license (license:x11-style "file://COPYRIGHT"))))
+
(define-public netcdf-parallel-openmpi
(package (inherit netcdf)
(name "netcdf-parallel-openmpi")