aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-09-30 08:34:34 +0000
committerEfraim Flashner <efraim@flashner.co.il>2024-09-30 10:38:15 +0000
commit1d4a44a29b75cb4d2ffe79aec135efbced02476a (patch)
treef082994e52408935065bdef4d78e2684da6054bc
parentedfdc905d9438d502de95b8db43073ccd7cd1b7f (diff)
downloadguix-1d4a44a29b75cb4d2ffe79aec135efbced02476a.tar
guix-1d4a44a29b75cb4d2ffe79aec135efbced02476a.tar.gz
guix-1d4a44a29b75cb4d2ffe79aec135efbced02476a.tar.bz2
guix-1d4a44a29b75cb4d2ffe79aec135efbced02476a.tar.lz
guix-1d4a44a29b75cb4d2ffe79aec135efbced02476a.tar.xz
guix-1d4a44a29b75cb4d2ffe79aec135efbced02476a.tar.zst
guix-1d4a44a29b75cb4d2ffe79aec135efbced02476a.zip
gnu: gcc-14: Add tuning target.
* gnu/packages/gcc.scm (%gcc-14-x86_64-micro-architectures): New variable. (gcc-14)[properties]: Use it. Change-Id: I00f9e2a4c9d590f97977275b157002ac330b895b
-rw-r--r--gnu/packages/gcc.scm14
1 files changed, 13 insertions, 1 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 7fceb4be96..c6c7730ad1 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -645,6 +645,10 @@ Go. It also includes runtime support libraries for these languages.")
(append %gcc-12-x86_64-micro-architectures
'("graniterapids"))) ;Intel
+(define %gcc-14-x86_64-micro-architectures
+ (append %gcc-13-x86_64-micro-architectures
+ '("znver5"))) ;AMD
+
(define-public gcc-7
(package
(inherit gcc-6)
@@ -839,7 +843,15 @@ It also includes runtime support libraries for these languages.")
(add-before 'configure 'pre-x86-configure
(lambda _
(substitute* "gcc/config/i386/t-linux64"
- (("\\.\\./lib64") "../lib"))))))))))
+ (("\\.\\./lib64") "../lib"))))))))
+ (properties
+ `((compiler-cpu-architectures
+ ("aarch64" ,@%gcc-13-aarch64-micro-architectures)
+ ("armhf" ,@%gcc-13-armhf-micro-architectures)
+ ("i686" ,@%gcc-13-x86_64-micro-architectures)
+ ("powerpc64le" ,@%gcc-10-ppc64le-micro-architectures)
+ ("x86_64" ,@%gcc-14-x86_64-micro-architectures))
+ ,@(package-properties gcc-11)))))
;; Note: When changing the default gcc version, update