aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-09-19 10:51:38 +0000
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-10-05 13:48:38 +0000
commit1ca236a02af88954c192b6858a65e454be307eaa (patch)
tree2e393356f76fbf9bc64fecd51da3a184ae7d2fc7
parent7975585559d29ebd16c8fe20dc46be44634e0e2f (diff)
downloadguix-1ca236a02af88954c192b6858a65e454be307eaa.tar
guix-1ca236a02af88954c192b6858a65e454be307eaa.tar.gz
guix-1ca236a02af88954c192b6858a65e454be307eaa.tar.bz2
guix-1ca236a02af88954c192b6858a65e454be307eaa.tar.lz
guix-1ca236a02af88954c192b6858a65e454be307eaa.tar.xz
guix-1ca236a02af88954c192b6858a65e454be307eaa.tar.zst
guix-1ca236a02af88954c192b6858a65e454be307eaa.zip
gnu: bsnes: Remove input labels and use gexps.
* gnu/packages/emulators.scm (bsnes) [arguments]: Use gexps. [inputs]: Remove labels. [home-page]: Update URL. Change-Id: I69046d977c4647f46c1359d62b762149b8f70160
-rw-r--r--gnu/packages/emulators.scm43
1 files changed, 21 insertions, 22 deletions
diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index 4dc61bdbff..50a7b67121 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -2230,31 +2230,30 @@ from various forks of Gens, and improved platform portability.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32
- "0j054x38fwai61vj36sc04r3zkzay5acq2cgd9zqv5hs51s36g5b"))))
+ (base32 "0j054x38fwai61vj36sc04r3zkzay5acq2cgd9zqv5hs51s36g5b"))))
(build-system gnu-build-system)
(arguments
- `(#:make-flags (list "-C" "bsnes"
- ;; Remove march=native
- "local=false"
- (string-append "prefix=" (assoc-ref %outputs "out")))
- #:tests? #f ; No tests.
- #:phases (modify-phases %standard-phases
- (delete 'configure))))
- (native-inputs
- (list pkg-config))
+ (list
+ #:make-flags #~(list "-C" "bsnes"
+ ;; Remove march=native
+ "local=false"
+ (string-append "prefix=" #$output))
+ #:tests? #f ;No tests.
+ #:phases #~(modify-phases %standard-phases
+ (delete 'configure))))
+ (native-inputs (list pkg-config))
(inputs
- `(("alsa-lib" ,alsa-lib)
- ("ao" ,ao)
- ("cairo" ,cairo)
- ("eudev" ,eudev)
- ("gtksourceview-2" ,gtksourceview-2)
- ("libxrandr" ,libxrandr)
- ("libxv" ,libxv)
- ("openal" ,openal)
- ("pulseaudio" ,pulseaudio)
- ("sdl2" ,sdl2)))
- (home-page "https://bsnes.dev/")
+ (list alsa-lib
+ ao
+ cairo
+ eudev
+ gtksourceview-2
+ libxrandr
+ libxv
+ openal
+ pulseaudio
+ sdl2))
+ (home-page "https://github.com/bsnes-emu/bsnes")
(synopsis "Emulator for the Super Nintendo / Super Famicom systems")
(description
"bsnes is a Super Nintendo / Super Famicom emulator that focuses on