aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/rust-apps.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/rust-apps.scm')
-rw-r--r--gnu/packages/rust-apps.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index 12205ef1aa..967d628d8a 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -3105,6 +3105,31 @@ JSON IPC interface. The swayr client offers subcommands, and sends them to the
daemon which executes them.")
(license license:gpl3+)))
+(define-public swaysome
+ (package
+ (name "swaysome")
+ (version "2.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "swaysome" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "02lvq4pr7dbslxvlhfha6rhbqfmj8a6kq0p41b25a56p0pwhd7qq"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-byteorder" ,rust-byteorder-1)
+ ("rust-clap" ,rust-clap-4)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-serde-json" ,rust-serde-json-1))))
+ (home-page "https://gitlab.com/hyask/swaysome")
+ (synopsis
+ "Awesome way to manage your multiple outputs with the sway windows manager")
+ (description
+ "This package provides swaysome provides an awesome way to manage your multiple
+outputs with the sway windows manager.")
+ (license license:expat)))
+
(define-public tealdeer
(package
(name "tealdeer")