aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/astronomy.scm13
1 files changed, 10 insertions, 3 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index cad6624de4..730831168e 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -3076,9 +3076,16 @@ Carlo.")
(build-system pyproject-build-system)
(arguments
(list
- ;; Break cycle: python-ndcube -> python-specutils -> python-ndcube, see
- ;; <https://github.com/sunpy/ndcube/issues/733>.
- #:test-flags #~(list "-k" "not test_rebin_specutils")
+ #:test-flags
+ #~(list "-k" (string-append
+ ;; Break cycle: python-ndcube -> python-specutils ->
+ ;; python-ndcube, see
+ ;; <https://github.com/sunpy/ndcube/issues/733>.
+ "not test_rebin_specutils"
+ ;; Introduced with astropy 6.1.3, see
+ ;; <https://github.com/sunpy/ndcube/issues/758>.
+ " and not test_2d[celestial_2d_ape14_wcs]"
+ " and not test_2d[celestial_2d_fitswcs]"))
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'break-cycle