aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/lisp-xyz.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 164ec588f2..19871bd011 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -25994,6 +25994,38 @@ portable, safe printable, 7-bit ASCII format.")
(define-public ecl-s-base64
(sbcl-package->ecl-package sbcl-s-base64))
+(define-public sbcl-s-graphviz
+ (let ((commit "a06d9573f0d4e21751b0ae782515b63a40ad6eae")
+ (revision "1"))
+ (package
+ (name "sbcl-s-graphviz")
+ (version (git-version "2.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jingtaozf/s-graphviz")
+ (commit commit)))
+ (file-name (git-file-name "cl-s-graphviz" version))
+ (sha256
+ (base32 "1841xwci6y1gfhg15464wrlnw8xgsh1mwbg4yy2y7di02q4fbma2"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ (list sbcl-iterate))
+ (native-inputs
+ (list sbcl-literate-lisp))
+ (home-page "https://github.com/jingtaozf/s-graphviz")
+ (synopsis "S-expression representation of the GraphViz DOT language")
+ (description "This package creates GraphViz DOT files from
+an equivalent s-expression representation.")
+ (license license:expat))))
+
+(define-public cl-s-graphviz
+ (sbcl-package->cl-source-package sbcl-s-graphviz))
+
+(define-public ecl-s-graphviz
+ (sbcl-package->ecl-package sbcl-s-graphviz))
+
(define-public sbcl-s-sysdeps
;; No release since 2013.
(let ((commit "7f8de283b7fbd8b038fdf08493063a736db36ce7")