aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-17 08:25:14 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-09-30 21:06:30 +0000
commitfbf5cc8c4d397459693e859d7c55aa3a66de29dc (patch)
tree5fa37fca2e89a879625ef2c44fac833fe5a9bec4
parentbe3fdbe0918f416ea1807d4acdffbbe45bad15ca (diff)
downloadguix-fbf5cc8c4d397459693e859d7c55aa3a66de29dc.tar
guix-fbf5cc8c4d397459693e859d7c55aa3a66de29dc.tar.gz
guix-fbf5cc8c4d397459693e859d7c55aa3a66de29dc.tar.bz2
guix-fbf5cc8c4d397459693e859d7c55aa3a66de29dc.tar.lz
guix-fbf5cc8c4d397459693e859d7c55aa3a66de29dc.tar.xz
guix-fbf5cc8c4d397459693e859d7c55aa3a66de29dc.tar.zst
guix-fbf5cc8c4d397459693e859d7c55aa3a66de29dc.zip
gnu: python-astropy: Update to 6.1.3.
* gnu/packages/astronomy.scm (python-astropy): Update to 6.1.3. [arguments]: <#:test-flags>: Enable more tests. Change-Id: Id9ad7141bcc06f45bc8408896fc216b655b49642
-rw-r--r--gnu/packages/astronomy.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 0de3bce59a..cad6624de4 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2171,13 +2171,13 @@ objects.")
(define-public python-astropy
(package
(name "python-astropy")
- (version "6.1.2")
+ (version "6.1.3")
(source
(origin
(method url-fetch)
(uri (pypi-uri "astropy" version))
(sha256
- (base32 "0fhx9zjsqp7z8z8phafpbwpb46idrbsamkfg42l8j0z94i73s452"))
+ (base32 "0w09fn7zy2nr5pvvqwmi3s3cm3y5pzxpn7wldz7bbxn1xp6k9j4s"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -2195,15 +2195,13 @@ objects.")
(list
#:test-flags
#~(list "--pyargs" "astropy"
- "-n" "auto"
+ "--numprocesses" "auto"
"-k" (string-append
;; Skip tests that need remote data.
"not remote_data"
;; ValueError: The truth value of an array with more than
;; one element is ambiguous. Use a.any() or a.all()
- " and not test_table_comp[t16-t26]"
- ;; E Unreliable test timings! <...>
- " and not test_datetime_timedelta_roundtrip"))
+ " and not test_table_comp[t16-t26]"))
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'preparations