aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Faiz via Guix-patches via <guix-patches@gnu.org>2024-08-06 13:09:17 +0000
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-10-05 18:41:29 +0000
commitea47842d29873d1dfcb1435262e458446f27c7d7 (patch)
tree77da73d9bac24318854417163e218da2929238ea
parent37dede4c4d8c25a786f2a2e2a17ba54b4ba6283f (diff)
downloadguix-ea47842d29873d1dfcb1435262e458446f27c7d7.tar
guix-ea47842d29873d1dfcb1435262e458446f27c7d7.tar.gz
guix-ea47842d29873d1dfcb1435262e458446f27c7d7.tar.bz2
guix-ea47842d29873d1dfcb1435262e458446f27c7d7.tar.lz
guix-ea47842d29873d1dfcb1435262e458446f27c7d7.tar.xz
guix-ea47842d29873d1dfcb1435262e458446f27c7d7.tar.zst
guix-ea47842d29873d1dfcb1435262e458446f27c7d7.zip
gnu: libtorrent-rasterbar: Use gexps and new input style.
* gnu/packages/bittorrent.scm (libtorrent-rasterbar)[arguments]: Use gexps. [native-inputs]: Drop labels. Signed-off-by: Zheng Junjie <zhengjunjie@iscas.ac.cn> Change-Id: Ic6dc52ab422e479c941a1f33abdb64fb81c3229d
-rw-r--r--gnu/packages/bittorrent.scm98
1 files changed, 50 insertions, 48 deletions
diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index 31c0250916..2b38c7cb65 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -434,55 +434,57 @@ and will take advantage of multiple processor cores where possible.")
(base32 "0pc8rbcp7njbx8m02z47pcbbwcp5cjggbgq4sfjc19dc3n65p4zw"))))
(build-system cmake-build-system)
(arguments
- `(#:configure-flags '("-Dpython-bindings=ON"
- "-Dbuild_tests=ON")
- ;; Tests do not reliably work when executed in parallel.
- #:parallel-tests? #f
- #:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? parallel-tests? #:allow-other-keys)
- (let* ((disabled-tests
- '(
- ;; Requires a non-localhost IPv4 interface.
- "test_upnp"
- ;; test_ssl needs to be run separately.
- "test_ssl"))
- (exclude-regex (string-append "^("
- (string-join disabled-tests "|")
- ")$"))
- (timeout "600")
- (jobs (if parallel-tests?
- (number->string (parallel-job-count))
- "1")))
- (when tests?
- (invoke "ctest"
- "-E" exclude-regex
- "-j" jobs
- "--timeout" timeout
- "--output-on-failure")
- ;; test_ssl relies on bundled TLS certificates with a fixed
- ;; expiry date. To ensure succesful builds in the future,
- ;; fake the time to be roughly that of the release.
- ;;
- ;; At the same time, faketime happens to cause
- ;; test_fast_extension, test_privacy and test_resolve_links
- ;; to hang, even with FAKETIME_ONLY_CMDS. Not sure why. So
- ;; execute only test_ssl under faketime.
- ;;
- ;; Note: The test_ssl test times out in the ci.
- ;; Temporarily disable it until that is resolved.
- ;; (invoke "faketime" "2022-10-24"
- ;; "ctest"
- ;; "-R" "^test_ssl$"
- ;; "-j" jobs
- ;; "--timeout" timeout
- ;; "--output-on-failure")
- )))))))
+ (list
+ #:configure-flags
+ #~(list "-Dpython-bindings=ON"
+ "-Dbuild_tests=ON")
+ ;; Tests do not reliably work when executed in parallel.
+ #:parallel-tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? parallel-tests? #:allow-other-keys)
+ (let* ((disabled-tests
+ '(;; Requires a non-localhost IPv4 interface.
+ "test_upnp"
+ ;; test_ssl needs to be run separately.
+ "test_ssl"))
+ (exclude-regex (string-append "^("
+ (string-join disabled-tests "|")
+ ")$"))
+ (timeout "600")
+ (jobs (if parallel-tests?
+ (number->string (parallel-job-count))
+ "1")))
+ (when tests?
+ (invoke "ctest"
+ "-E" exclude-regex
+ "-j" jobs
+ "--timeout" timeout
+ "--output-on-failure")
+ ;; test_ssl relies on bundled TLS certificates with a fixed
+ ;; expiry date. To ensure succesful builds in the future,
+ ;; fake the time to be roughly that of the release.
+ ;;
+ ;; At the same time, faketime happens to cause
+ ;; test_fast_extension, test_privacy and test_resolve_links
+ ;; to hang, even with FAKETIME_ONLY_CMDS. Not sure why. So
+ ;; execute only test_ssl under faketime.
+ ;;
+ ;; Note: The test_ssl test times out in the ci.
+ ;; Temporarily disable it until that is resolved.
+ ;; (invoke "faketime" "2022-10-24"
+ ;; "ctest"
+ ;; "-R" "^test_ssl$"
+ ;; "-j" jobs
+ ;; "--timeout" timeout
+ ;; "--output-on-failure")
+ )))))))
(inputs (list boost openssl))
- (native-inputs `(("libfaketime" ,libfaketime)
- ("python-wrapper" ,python-wrapper)
- ("pkg-config" ,pkg-config)))
+ (native-inputs
+ (list libfaketime
+ python-wrapper
+ pkg-config))
(home-page "https://www.libtorrent.org/")
(synopsis "Feature-complete BitTorrent implementation")
(description