aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-09-27 02:54:46 +0000
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-10-06 16:20:21 +0000
commitd43fd988c5cbadfb621bc605657bfa0b20d98d08 (patch)
treea2544519d8b123424a66a4d2de1b65c3f4d8c574
parentb759a9ffdfd8f38043c8100e9984ebecd34360f9 (diff)
downloadguix-d43fd988c5cbadfb621bc605657bfa0b20d98d08.tar
guix-d43fd988c5cbadfb621bc605657bfa0b20d98d08.tar.gz
guix-d43fd988c5cbadfb621bc605657bfa0b20d98d08.tar.bz2
guix-d43fd988c5cbadfb621bc605657bfa0b20d98d08.tar.lz
guix-d43fd988c5cbadfb621bc605657bfa0b20d98d08.tar.xz
guix-d43fd988c5cbadfb621bc605657bfa0b20d98d08.tar.zst
guix-d43fd988c5cbadfb621bc605657bfa0b20d98d08.zip
gnu: retroarch: Use gexps.
* gnu/packages/emulators.scm (retroarch) [arguments] <phases>: Use gexps; locate resources using `search-input-file' and `search-input-directory'. Change-Id: I0b1c4ff074e6f8287c14ac3327a8d0271391fec2
-rw-r--r--gnu/packages/emulators.scm70
1 files changed, 34 insertions, 36 deletions
diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index a1e5a1f0c9..92156f10df 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -1592,43 +1592,41 @@ physical device and the RetroPad virtual controller.")
(base32 "15nh4y4vpf4n1ryhiy4fwvzn5xz5idzfzn9fsi5v9hzp25vbjmrm"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; no tests
- #:phases
- (modify-phases %standard-phases
- (replace 'configure
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (etc (string-append out "/etc"))
- (vulkan (assoc-ref inputs "vulkan-loader"))
- (wayland-protocols (assoc-ref inputs "wayland-protocols")))
- ;; Hard-code some store file names.
- (substitute* "gfx/common/vulkan_common.c"
- (("libvulkan.so") (string-append vulkan "/lib/libvulkan.so")))
- (substitute* "gfx/common/wayland/generate_wayland_protos.sh"
- (("/usr/local/share/wayland-protocols")
- (string-append wayland-protocols "/share/wayland-protocols")))
-
- ;; Without HLSL, we can still enable GLSLANG and Vulkan support.
- (substitute* "qb/config.libs.sh"
- (("[$]HAVE_GLSLANG_HLSL") "notcare"))
-
- ;; The configure script does not yet accept the extra arguments
- ;; (like ‘CONFIG_SHELL=’) passed by the default configure phase.
- (invoke
- "./configure"
- ,@(if (string-prefix? "armhf" (or (%current-target-system)
+ (list
+ #:tests? #f ; no tests
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; Hard-code some store file names.
+ (substitute* "gfx/common/vulkan_common.c"
+ (("libvulkan.so")
+ (search-input-file inputs "lib/libvulkan.so")))
+ (substitute* "gfx/common/wayland/generate_wayland_protos.sh"
+ (("/usr/local/share/wayland-protocols")
+ (search-input-directory inputs "share/wayland-protocols")))
+
+ ;; Without HLSL, we can still enable GLSLANG and Vulkan support.
+ (substitute* "qb/config.libs.sh"
+ (("[$]HAVE_GLSLANG_HLSL") "notcare"))
+
+ ;; The configure script does not yet accept the extra arguments
+ ;; (like ‘CONFIG_SHELL=’) passed by the default configure phase.
+ (invoke
+ "./configure"
+ #$@(if (string-prefix? "armhf" (or (%current-target-system)
(%current-system)))
- '("--enable-neon" "--enable-floathard")
- '())
- (string-append "--prefix=" out)
- ;; Non-free software are available through the core updater,
- ;; disable it. See <https://issues.guix.gnu.org/38360>.
- "--disable-update_cores"
- "--disable-builtinmbedtls"
- "--disable-builtinbearssl"
- "--disable-builtinzlib"
- "--disable-builtinflac"
- "--disable-builtinglslang")))))))
+ '("--enable-neon" "--enable-floathard")
+ '())
+ (string-append "--prefix=" #$output)
+ ;; Non-free software are available through the core updater,
+ ;; disable it. See <https://issues.guix.gnu.org/38360>.
+ "--disable-update_cores"
+ "--disable-builtinmbedtls"
+ "--disable-builtinbearssl"
+ "--disable-builtinzlib"
+ "--disable-builtinflac"
+ "--disable-builtinglslang"))))))
(inputs
(list alsa-lib
eudev