aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSören Tempel <soeren@soeren-tempel.net>2024-09-27 18:35:02 +0000
committerLudovic Courtès <ludo@gnu.org>2024-10-07 10:51:24 +0000
commitc3d21302cbd1118c8ae4fdcf85c055239b1689ab (patch)
tree015eac1921d5e7b8fd8a1abfc5590daca840a48a
parent53c7ce9c9aafabcdf2e4a7bbafe76b4205220297 (diff)
downloadguix-c3d21302cbd1118c8ae4fdcf85c055239b1689ab.tar
guix-c3d21302cbd1118c8ae4fdcf85c055239b1689ab.tar.gz
guix-c3d21302cbd1118c8ae4fdcf85c055239b1689ab.tar.bz2
guix-c3d21302cbd1118c8ae4fdcf85c055239b1689ab.tar.lz
guix-c3d21302cbd1118c8ae4fdcf85c055239b1689ab.tar.xz
guix-c3d21302cbd1118c8ae4fdcf85c055239b1689ab.tar.zst
guix-c3d21302cbd1118c8ae4fdcf85c055239b1689ab.zip
gnu: Add python-unique-log-filter.
* gnu/packages/python-xyz.scm (python-unique-log-filter): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python-xyz.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index be095bdb4a..aa74a16b45 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -31033,6 +31033,36 @@ as JSON objects. With JSON we can make our logs more readable by machines and
we can stop writing custom parsers for syslog-type records.")
(license license:bsd-3)))
+(define-public python-unique-log-filter
+ (package
+ (name "python-unique-log-filter")
+ (version "0.1.0")
+ (source
+ ;; The version on pypi does not include test files.
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/twizmwazin/unique_log_filter")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "036mh6nqskck2fa1q2inasqxb9wcz2p09qcpldnnffzcy1a6kzba"))))
+ (build-system pyproject-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "python" "test_unique_log_filter.py")))))))
+ (native-inputs (list python-flit-core))
+ (home-page "https://github.com/twizmwazin/unique_log_filter")
+ (synopsis "Log filter that removes duplicate log messages")
+ (description
+ "This library provides a filter for the @code{logging} module
+from the Python standard library which allows removing duplicate log
+messages.")
+ (license license:bsd-2)))
+
(define-public python-daiquiri
(package
(name "python-daiquiri")