aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRomain GARBAGE <romain.garbage@inria.fr>2024-10-02 15:40:01 +0000
committerLudovic Courtès <ludo@gnu.org>2024-10-04 15:23:13 +0000
commita227a6efb59b7535d4223110760e7be6f4754fc6 (patch)
treee6ab460470489059fe3112ff8c1ae42c8f359bc2
parent26d1b6b3c9a7322bbdbb01f39dbdeff43c863595 (diff)
downloadguix-a227a6efb59b7535d4223110760e7be6f4754fc6.tar
guix-a227a6efb59b7535d4223110760e7be6f4754fc6.tar.gz
guix-a227a6efb59b7535d4223110760e7be6f4754fc6.tar.bz2
guix-a227a6efb59b7535d4223110760e7be6f4754fc6.tar.lz
guix-a227a6efb59b7535d4223110760e7be6f4754fc6.tar.xz
guix-a227a6efb59b7535d4223110760e7be6f4754fc6.tar.zst
guix-a227a6efb59b7535d4223110760e7be6f4754fc6.zip
gnu: netcdf-parallel-openmpi: Enable pnetcdf support.
* gnu/packages/maths.scm (netcdf-parallel-openmpi) [arguments]: Enable pnetcdf support. Change-Id: I7f3fc6abdb262be86840ea3f68bb6416a0ab1fad Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/maths.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 51812c5a0d..f4edd546e2 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -2386,6 +2386,7 @@ Unidata's NetCDF, files in classic formats, specifically the formats of CDF-1, 2
(name "netcdf-parallel-openmpi")
(inputs
`(("mpi" ,openmpi)
+ ("pnetcdf" ,pnetcdf)
,@(alist-replace "hdf5" (list hdf5-parallel-openmpi)
(package-inputs netcdf))))
;; TODO: Replace pkg-config references in nc-config with absolute references
@@ -2394,6 +2395,8 @@ Unidata's NetCDF, files in classic formats, specifically the formats of CDF-1, 2
((#:configure-flags flags)
`(cons* "CC=mpicc" "CXX=mpicxx"
"--enable-parallel-tests"
+ ;; Enable support of CDF-1, 2 and 5 formats.
+ "--enable-pnetcdf"
;; NetCDF supports both parallel and shared library building
;; See https://docs.unidata.ucar.edu/nug/current/getting_and_building_netcdf.html#build_parallel
"--enable-shared" "--with-pic"