aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-11 13:10:53 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-09-30 21:06:32 +0000
commit213eae66c7a288ca8293065a95297c2df885454d (patch)
treed632fdaa24314516d34b2b4d21620014b950a4dc
parentf547dd668f7c23ac72ee6c084dfe405536af1d67 (diff)
downloadguix-213eae66c7a288ca8293065a95297c2df885454d.tar
guix-213eae66c7a288ca8293065a95297c2df885454d.tar.gz
guix-213eae66c7a288ca8293065a95297c2df885454d.tar.bz2
guix-213eae66c7a288ca8293065a95297c2df885454d.tar.lz
guix-213eae66c7a288ca8293065a95297c2df885454d.tar.xz
guix-213eae66c7a288ca8293065a95297c2df885454d.tar.zst
guix-213eae66c7a288ca8293065a95297c2df885454d.zip
gnu: Add healpix-cxx.
* gnu/packages/astronomy.scm (healpix-cxx): New variable. Change-Id: I1d70cd44efa86f89e3fc8f4f60d0b259ecd78acf
-rw-r--r--gnu/packages/astronomy.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 3ca8c50b9a..7e69584127 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -663,6 +663,36 @@ covers the same surface area as every other pixel. This package provides the
dynamic library for the C language implementation of HEALPix.")
(license license:gpl2+)))
+(define-public healpix-cxx
+ (package
+ (inherit healpix)
+ (name "healpix-cxx")
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'chdir-cxx
+ (lambda _
+ (chdir "src/cxx")))
+ (add-after 'chdir-cxx 'adjust-unit-tests
+ (lambda _
+ (substitute* "configure.ac"
+ ;; Run unit tests using serial harness, taken from
+ ;; <https://salsa.debian.org/debian-astro-team/healpix-cxx/>.
+ (("foreign subdir-objects -Wall -Werror")
+ "foreign serial-tests subdir-objects -Wall -Werror"))))
+ (replace 'bootstrap
+ (lambda _
+ (invoke "aclocal")
+ (invoke "automake" "--add-missing")
+ (invoke "autoconf"))))))
+ (inputs (modify-inputs (package-inputs healpix)
+ (prepend libsharp zlib)))
+ (description
+ (string-replace-substring (package-description healpix)
+ "C language"
+ "C++ language"))))
+
(define-public erfa
(package
(name "erfa")