aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-09-28 06:53:19 +0000
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-10-06 16:20:21 +0000
commit0b6caa6d17ccb347d97ca3038005cc1f8d1b33cc (patch)
tree7a608b785daf00b8b735d38a24be7363f40b8525
parentd8b34052b2ced0095f1bd8a854a6ae718f34a966 (diff)
downloadguix-0b6caa6d17ccb347d97ca3038005cc1f8d1b33cc.tar
guix-0b6caa6d17ccb347d97ca3038005cc1f8d1b33cc.tar.gz
guix-0b6caa6d17ccb347d97ca3038005cc1f8d1b33cc.tar.bz2
guix-0b6caa6d17ccb347d97ca3038005cc1f8d1b33cc.tar.lz
guix-0b6caa6d17ccb347d97ca3038005cc1f8d1b33cc.tar.xz
guix-0b6caa6d17ccb347d97ca3038005cc1f8d1b33cc.tar.zst
guix-0b6caa6d17ccb347d97ca3038005cc1f8d1b33cc.zip
gnu: Add libretro-mupen64plus-nx.
* gnu/packages/emulators.scm (libretro-mupen64plus-nx): New variable. Change-Id: I2249a41722478d340ac4ca2d6d96fa8ae525d1f6
-rw-r--r--gnu/packages/emulators.scm56
1 files changed, 56 insertions, 0 deletions
diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index dae8b7097c..21570ada74 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -1495,6 +1495,62 @@ core allowing the lowRES NX programs to be used with libretro frontends such
as RetroArch.")
(license license:zlib)))
+(define-public libretro-mupen64plus-nx
+ ;; There are no proper release; use the latest commit of the master branch
+ ;; (their stable branch).
+ (let ((commit "9d940bacb95c4d86733f42b67b57fc83046a6d39")
+ (revision "0"))
+ (package
+ (name "libretro-mupen64plus-nx")
+ (version (git-version "0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/libretro/mupen64plus-libretro-nx")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0s3l62mfkbzmv8g1y4r40iayfwdz68rq6l6khc0d8kw08qk7ggl9"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:tests? #f ;no test suite
+ #:make-flags
+ #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "CXX=" #$(cxx-for-target))
+ (string-append "GIT_VERSION=" #$version)
+ (string-append "PREFIX=" #$output)
+ "LLE=1"
+ "HAVE_THR_AL=1" ;for the angrylion video plugin
+ "HAVE_PARALLEL_RDP=1"
+ "HAVE_PARALLEL_RSP=1"
+ "SYSTEM_MINIZIP=1"
+ "SYSTEM_LIBPNG=1"
+ "SYSTEM_XXHASH=1"
+ "SYSTEM_ZLIB=1")
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'install
+ (lambda _
+ (install-file "mupen64plus_next_libretro.so"
+ (string-append #$output "/lib/libretro/")))))))
+ (native-inputs (list nasm pkg-config))
+ (inputs (list mesa libpng minizip unzip xxhash zlib))
+ (home-page "https://github.com/libretro/mupen64plus-libretro-nx")
+ (synopsis "Improved Mupen64Plus libretro core")
+ (description "Mupen64Plus-Next is a N64 emulation library for the
+libretro API, based on Mupen64Plus. It incorporates the following projects:
+@itemize
+@item @url{https://github.com/mupen64plus/mupen64plus-core, mupen64plus}
+@item @url{https://github.com/gonetz/GLideN64, GLideN64}
+@item @url{https://github.com/cxd4/rsp, cxd4}
+@item @url{https://github.com/Themaister/parallel-rsp, parallel-rsp}
+@item @url{https://github.com/ata4/angrylion-rdp-plus, angrylion-rdp-plus}
+@end itemize")
+ (license license:gpl2+))))
+
(define-public retroarch-assets
(package
(name "retroarch-assets")