aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve George <steve@futurile.net>2024-10-03 20:09:33 +0000
committerEfraim Flashner <efraim@flashner.co.il>2024-10-10 11:46:23 +0000
commit763a49b84fdb3c7456407cf26d26e84b3e05d413 (patch)
tree1ba2b3b8df81c4c235bf774cad05798ddc1e168b
parentf1a9cf03cccc99d637c1ce4f8faa9ec46be0ba58 (diff)
downloadguix-763a49b84fdb3c7456407cf26d26e84b3e05d413.tar
guix-763a49b84fdb3c7456407cf26d26e84b3e05d413.tar.gz
guix-763a49b84fdb3c7456407cf26d26e84b3e05d413.tar.bz2
guix-763a49b84fdb3c7456407cf26d26e84b3e05d413.tar.lz
guix-763a49b84fdb3c7456407cf26d26e84b3e05d413.tar.xz
guix-763a49b84fdb3c7456407cf26d26e84b3e05d413.tar.zst
guix-763a49b84fdb3c7456407cf26d26e84b3e05d413.zip
gnu: Add rust-gix-traverse-0.41.
* gnu/packages/crates-vcs.scm (rust-gix-traverse-0.41): New variable. (rust-gix-traverse-0.36): Inherit from rust-gix-traverse-0.41. Change-Id: I9b2cf3111c8608006da5491595a6686f9896fec9
-rw-r--r--gnu/packages/crates-vcs.scm38
1 files changed, 31 insertions, 7 deletions
diff --git a/gnu/packages/crates-vcs.scm b/gnu/packages/crates-vcs.scm
index 8db798e01b..642f8dbbbc 100644
--- a/gnu/packages/crates-vcs.scm
+++ b/gnu/packages/crates-vcs.scm
@@ -5704,8 +5704,38 @@ provides an implementation of the Git transport layer.")
("rust-blocking" ,rust-blocking-1)
("rust-maybe-async" ,rust-maybe-async-0.2))))))
+(define-public rust-gix-traverse-0.41
+ (package
+ (name "rust-gix-traverse")
+ (version "0.41.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "gix-traverse" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "105prigk1pq7g3i3hvwh4y9rhc35ycl84cg9f9ag6kafz6da6383"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-bitflags" ,rust-bitflags-2)
+ ("rust-gix-commitgraph" ,rust-gix-commitgraph-0.24)
+ ("rust-gix-date" ,rust-gix-date-0.9)
+ ("rust-gix-hash" ,rust-gix-hash-0.14)
+ ("rust-gix-hashtable" ,rust-gix-hashtable-0.5)
+ ("rust-gix-object" ,rust-gix-object-0.44)
+ ("rust-gix-revwalk" ,rust-gix-revwalk-0.15)
+ ("rust-smallvec" ,rust-smallvec-1)
+ ("rust-thiserror" ,rust-thiserror-1))))
+ (home-page "https://github.com/Byron/gitoxide")
+ (synopsis "Ways to traverse Git commit graphs and trees for Gix")
+ (description "Part of Gitoxide, a pure Rust implementation of Git. This
+package is used to traverse Git commit graphs and trees.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-gix-traverse-0.36
(package
+ (inherit rust-gix-traverse-0.41)
(name "rust-gix-traverse")
(version "0.36.2")
(source
@@ -5715,7 +5745,6 @@ provides an implementation of the Git transport layer.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32 "0qbiq230wj8ak60zzg613pgflwnvsyj71x9liys0k957bd29w435"))))
- (build-system cargo-build-system)
(arguments
`(#:cargo-inputs (("rust-gix-commitgraph" ,rust-gix-commitgraph-0.23)
("rust-gix-date" ,rust-gix-date-0.8)
@@ -5724,12 +5753,7 @@ provides an implementation of the Git transport layer.")
("rust-gix-object" ,rust-gix-object-0.40)
("rust-gix-revwalk" ,rust-gix-revwalk-0.11)
("rust-smallvec" ,rust-smallvec-1)
- ("rust-thiserror" ,rust-thiserror-1))))
- (home-page "https://github.com/Byron/gitoxide")
- (synopsis "Ways to traverse Git commit graphs and trees for Gix")
- (description "Part of Gitoxide, a pure Rust implementation of Git. This
-package is used to traverse Git commit graphs and trees.")
- (license (list license:expat license:asl2.0))))
+ ("rust-thiserror" ,rust-thiserror-1))))))
(define-public rust-gix-traverse-0.35
(package