aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Matei Pintilie <luca@lucamatei.com>2024-10-11 19:39:06 +0000
committerLuca Matei Pintilie <luca@lucamatei.com>2024-10-11 20:23:12 +0000
commit71b172e5964fef563a35fd9053772677608234b8 (patch)
tree92c9aba15aecca83e2095cf43615afa562507552
parent9019d7b61b4d4e8279d002a3bd5d186982ba86cd (diff)
downloadguix-user/luca/swaysome.tar
guix-user/luca/swaysome.tar.gz
guix-user/luca/swaysome.tar.bz2
guix-user/luca/swaysome.tar.lz
guix-user/luca/swaysome.tar.xz
guix-user/luca/swaysome.tar.zst
guix-user/luca/swaysome.zip
gnu: Add swaysomeuser/luca/swaysome
Signed-off-by: Luca Matei Pintilie <luca@lucamatei.com> Change-Id: I7e9b43b875cfdf68131b0fcff99721655c5af2d0
-rw-r--r--gnu/packages/rust-apps.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index 12205ef1aa..967d628d8a 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -3105,6 +3105,31 @@ JSON IPC interface. The swayr client offers subcommands, and sends them to the
daemon which executes them.")
(license license:gpl3+)))
+(define-public swaysome
+ (package
+ (name "swaysome")
+ (version "2.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "swaysome" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "02lvq4pr7dbslxvlhfha6rhbqfmj8a6kq0p41b25a56p0pwhd7qq"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-byteorder" ,rust-byteorder-1)
+ ("rust-clap" ,rust-clap-4)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-serde-json" ,rust-serde-json-1))))
+ (home-page "https://gitlab.com/hyask/swaysome")
+ (synopsis
+ "Awesome way to manage your multiple outputs with the sway windows manager")
+ (description
+ "This package provides swaysome provides an awesome way to manage your multiple
+outputs with the sway windows manager.")
+ (license license:expat)))
+
(define-public tealdeer
(package
(name "tealdeer")