aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Matei Pintilie <luca@lucamatei.com>2024-10-12 08:25:28 +0000
committerLuca Matei Pintilie <luca@lucamatei.com>2024-10-14 18:33:31 +0000
commitae5634d807b183fe3ba0b7dbc2afaeca39e72416 (patch)
tree26c12212dc43785107e81b7bdb864384b1e468f4
parent0988fcb50e1260e502223a2c9142ab41f574928f (diff)
downloadguix-ae5634d807b183fe3ba0b7dbc2afaeca39e72416.tar
guix-ae5634d807b183fe3ba0b7dbc2afaeca39e72416.tar.gz
guix-ae5634d807b183fe3ba0b7dbc2afaeca39e72416.tar.bz2
guix-ae5634d807b183fe3ba0b7dbc2afaeca39e72416.tar.lz
guix-ae5634d807b183fe3ba0b7dbc2afaeca39e72416.tar.xz
guix-ae5634d807b183fe3ba0b7dbc2afaeca39e72416.tar.zst
guix-ae5634d807b183fe3ba0b7dbc2afaeca39e72416.zip
gnu: Add rust-windows-0.57
Change-Id: I745f4431806045962496f6067c0f379aea062d80
-rw-r--r--gnu/packages/crates-windows.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/crates-windows.scm b/gnu/packages/crates-windows.scm
index 2c7a308ec4..3bb3ad3fd0 100644
--- a/gnu/packages/crates-windows.scm
+++ b/gnu/packages/crates-windows.scm
@@ -1352,6 +1352,26 @@ describing the API and right into your Rust package where you can call them as
if they were just another Rust module.")
(license (list license:expat license:asl2.0))))
+(define-public rust-windows-0.57
+ (package
+ (name "rust-windows")
+ (version "0.57.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "windows" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0hqid10bqvxa3pbpgvrh2cilf950lxsd9zqfv3rldc73v2s2qd0j"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-windows-core" ,rust-windows-core-0.57)
+ ("rust-windows-targets" ,rust-windows-targets-0.52))))
+ (home-page "https://github.com/microsoft/windows-rs")
+ (synopsis "Rust for Windows")
+ (description "This package provides Rust for Windows.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-windows-0.52
(package
(inherit rust-windows-0.58)