aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve George <steve@futurile.net>2024-10-04 20:47:48 +0000
committerEfraim Flashner <efraim@flashner.co.il>2024-10-10 11:46:26 +0000
commit74ffb5ef8191a863bcb5f68ecaf1af316981efc8 (patch)
treeca39dc90b2de89e7a0d7c5630913a61a2ae370e5
parentaa3790a22389842b0a4469645c0b460f69fcd793 (diff)
downloadguix-74ffb5ef8191a863bcb5f68ecaf1af316981efc8.tar
guix-74ffb5ef8191a863bcb5f68ecaf1af316981efc8.tar.gz
guix-74ffb5ef8191a863bcb5f68ecaf1af316981efc8.tar.bz2
guix-74ffb5ef8191a863bcb5f68ecaf1af316981efc8.tar.lz
guix-74ffb5ef8191a863bcb5f68ecaf1af316981efc8.tar.xz
guix-74ffb5ef8191a863bcb5f68ecaf1af316981efc8.tar.zst
guix-74ffb5ef8191a863bcb5f68ecaf1af316981efc8.zip
gnu: Add rust-lockfree-object-pool-0.1.
* gnu/packages/crates-io.scm (rust-lockfree-object-pool-0.1): New variable. Change-Id: I3062fb75535d4790499a1c676e7a53126c940079
-rw-r--r--gnu/packages/crates-io.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index f39bc3a1a0..bc5bcdf3ec 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -40846,6 +40846,31 @@ network interfaces/adapters.")
(("rust-scopeguard" ,rust-scopeguard-0.3)
("rust-owning-ref" ,rust-owning-ref-0.4))))))
+(define-public rust-lockfree-object-pool-0.1
+ (package
+ (name "rust-lockfree-object-pool")
+ (version "0.1.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "lockfree-object-pool" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0bjm2g1g1avab86r02jb65iyd7hdi35khn1y81z4nba0511fyx4k"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-development-inputs
+ (("rust-criterion" ,rust-criterion-0.5)
+ ("rust-criterion-plot" ,rust-criterion-plot-0.5)
+ ("rust-object-pool" ,rust-object-pool-0.5)
+ ("rust-sharded-slab" ,rust-sharded-slab-0.1))))
+ (home-page "https://github.com/EVaillant/lockfree-object-pool")
+ (synopsis "Thread-safe object pool collection")
+ (description
+ "This package provides a thread-safe object pool collection with automatic return
+and attach/detach semantics.")
+ (license license:boost1.0)))
+
(define-public rust-log-0.4
(package
(name "rust-log")