aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Matei Pintilie <luca@lucamatei.com>2024-10-12 07:28:29 +0000
committerLuca Matei Pintilie <luca@lucamatei.com>2024-10-14 18:33:31 +0000
commit4636ebb2545165c17395c6c13107afac6acbe4d8 (patch)
tree10069e651769022b6440203b625ecffd36f1a468
parent446131384115be94ce7776087fe4e44d9d3fa4ad (diff)
downloadguix-4636ebb2545165c17395c6c13107afac6acbe4d8.tar
guix-4636ebb2545165c17395c6c13107afac6acbe4d8.tar.gz
guix-4636ebb2545165c17395c6c13107afac6acbe4d8.tar.bz2
guix-4636ebb2545165c17395c6c13107afac6acbe4d8.tar.lz
guix-4636ebb2545165c17395c6c13107afac6acbe4d8.tar.xz
guix-4636ebb2545165c17395c6c13107afac6acbe4d8.tar.zst
guix-4636ebb2545165c17395c6c13107afac6acbe4d8.zip
gnu: rust-regex-1: Update to 1.11.0
Change-Id: I0fa4cca1f74f5fbf744acea09541725de2ba1806
-rw-r--r--gnu/packages/crates-io.scm26
1 files changed, 12 insertions, 14 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 6a6f712092..3530bac7ff 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -63735,28 +63735,26 @@ memory to speed up reallocation.")
(define-public rust-regex-1
(package
(name "rust-regex")
- (version "1.10.6")
+ (version "1.11.0")
(source
(origin
(method url-fetch)
(uri (crate-uri "regex" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "06cnlxwzyqfbw1za1i7ks89ns4i2kr0lpg5ykx56b8v7dd6df6a2"))))
+ (base32 "1n5imk7yxam409ik5nagsjpwqvbg3f0g0mznd5drf549x1g0w81q"))))
(build-system cargo-build-system)
(arguments
- `(#:cargo-inputs
- (("rust-aho-corasick" ,rust-aho-corasick-1)
- ("rust-memchr" ,rust-memchr-2)
- ("rust-regex-automata" ,rust-regex-automata-0.4)
- ("rust-regex-syntax" ,rust-regex-syntax-0.8))
- #:cargo-development-inputs
- (("rust-anyhow" ,rust-anyhow-1)
- ("rust-doc-comment" ,rust-doc-comment-0.3)
- ("rust-env-logger" ,rust-env-logger-0.9)
- ("rust-once-cell" ,rust-once-cell-1)
- ("rust-quickcheck" ,rust-quickcheck-1)
- ("rust-regex-test" ,rust-regex-test-0.1))))
+ `(#:cargo-inputs (("rust-aho-corasick" ,rust-aho-corasick-1)
+ ("rust-memchr" ,rust-memchr-2)
+ ("rust-regex-automata" ,rust-regex-automata-0.4)
+ ("rust-regex-syntax" ,rust-regex-syntax-0.8))
+ #:cargo-development-inputs (("rust-anyhow" ,rust-anyhow-1)
+ ("rust-doc-comment" ,rust-doc-comment-0.3)
+ ("rust-env-logger" ,rust-env-logger-0.9)
+ ("rust-once-cell" ,rust-once-cell-1)
+ ("rust-quickcheck" ,rust-quickcheck-1)
+ ("rust-regex-test" ,rust-regex-test-0.1))))
(home-page "https://github.com/rust-lang/regex")
(synopsis "Regular expressions for Rust")
(description