aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve George <steve@futurile.net>2024-10-04 19:04:46 +0000
committerEfraim Flashner <efraim@flashner.co.il>2024-10-10 11:46:26 +0000
commitfe709fab8388910edb9b91bfbb52a64690a25a5e (patch)
tree2109fea544bd07ec393015ae34d182e3a53ee911
parent49b8a771091f0dcda2b2707dbfa3cc1c4011183b (diff)
downloadguix-fe709fab8388910edb9b91bfbb52a64690a25a5e.tar
guix-fe709fab8388910edb9b91bfbb52a64690a25a5e.tar.gz
guix-fe709fab8388910edb9b91bfbb52a64690a25a5e.tar.bz2
guix-fe709fab8388910edb9b91bfbb52a64690a25a5e.tar.lz
guix-fe709fab8388910edb9b91bfbb52a64690a25a5e.tar.xz
guix-fe709fab8388910edb9b91bfbb52a64690a25a5e.tar.zst
guix-fe709fab8388910edb9b91bfbb52a64690a25a5e.zip
gnu: Add rust-prodash-29.
* gnu/packages/crates-io.scm (rust-prodash-29): New variable. (rust-prodash-28): Inherit from rust-prodash-29. Change-Id: I6bd5498f8a776a69bd309f107e394d2077ba9a16
-rw-r--r--gnu/packages/crates-io.scm60
1 files changed, 53 insertions, 7 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index ea18393836..b0ea91d8ab 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -58120,8 +58120,61 @@ pseudo-filesystem.")
information.")
(license (list license:expat license:asl2.0))))
+(define-public rust-prodash-29
+ (package
+ (name "rust-prodash")
+ (version "29.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "prodash" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "09g3zx6bhp96inzvgny7hlcqwn1ph1hmwk3hpqvs8q8c0bbdhrm2"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-async-io" ,rust-async-io-2)
+ ("rust-bytesize" ,rust-bytesize-1)
+ ("rust-crosstermion" ,rust-crosstermion-0.14)
+ ("rust-ctrlc" ,rust-ctrlc-3)
+ ("rust-dashmap" ,rust-dashmap-6)
+ ("rust-futures-core" ,rust-futures-core-0.3)
+ ("rust-futures-lite" ,rust-futures-lite-2)
+ ("rust-human-format" ,rust-human-format-1)
+ ("rust-humantime" ,rust-humantime-2)
+ ("rust-is-terminal" ,rust-is-terminal-0.4)
+ ("rust-jiff" ,rust-jiff-0.1)
+ ("rust-log" ,rust-log-0.4)
+ ("rust-parking-lot" ,rust-parking-lot-0.12)
+ ("rust-ratatui" ,rust-ratatui-0.26)
+ ("rust-signal-hook" ,rust-signal-hook-0.3)
+ ("rust-tui-react" ,rust-tui-react-0.23)
+ ("rust-unicode-segmentation" ,rust-unicode-segmentation-1)
+ ("rust-unicode-width" ,rust-unicode-width-0.1))
+ #:cargo-development-inputs
+ (("rust-argh" ,rust-argh-0.1)
+ ("rust-async-executor" ,rust-async-executor-1)
+ ("rust-async-io" ,rust-async-io-2)
+ ("rust-blocking" ,rust-blocking-1)
+ ("rust-criterion" ,rust-criterion-0.5)
+ ("rust-env-logger" ,rust-env-logger-0.11)
+ ("rust-futures" ,rust-futures-0.3)
+ ("rust-futures-util" ,rust-futures-util-0.3)
+ ("rust-is-terminal" ,rust-is-terminal-0.4)
+ ("rust-once-cell" ,rust-once-cell-1)
+ ("rust-rand" ,rust-rand-0.8))))
+ (home-page "https://github.com/Byron/prodash")
+ (synopsis
+ "Dashboard for visualizing progress of asynchronous and possibly blocking tasks")
+ (description
+ "This package provides a dashboard for visualizing progress of asynchronous and
+possibly blocking tasks.")
+ (license license:expat)))
+
(define-public rust-prodash-28
(package
+ (inherit rust-prodash-29)
(name "rust-prodash")
(version "28.0.0")
(source
@@ -58131,7 +58184,6 @@ information.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32 "0y9d16s79168rc5k2djjb16vjcx27yargbfb6xz6m2mq4r6jcjkl"))))
- (build-system cargo-build-system)
(arguments
`(#:cargo-inputs (("rust-async-io" ,rust-async-io-2)
("rust-bytesize" ,rust-bytesize-1)
@@ -58162,12 +58214,6 @@ information.")
("rust-is-terminal" ,rust-is-terminal-0.4)
("rust-once-cell" ,rust-once-cell-1)
("rust-rand" ,rust-rand-0.8))))
- (home-page "https://github.com/Byron/prodash")
- (synopsis
- "Dashboard for visualizing progress of asynchronous and possibly blocking tasks")
- (description
- "This package provides a dashboard for visualizing the progress of asynchronous
-and possibly blocking tasks.")
(license license:expat)))
(define-public rust-prodash-26