aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Matei Pintilie <luca@lucamatei.com>2024-10-10 18:09:52 +0000
committerLuca Matei Pintilie <luca@lucamatei.com>2024-10-10 20:37:05 +0000
commitdc13ad55cd310f13223818d9fc64ac1eea8e4a1b (patch)
tree9c87d36bb1315d59e9e2fb2a87337620826391d7
parent88530537893f47185a3319fd06fe9530599b80af (diff)
downloadguix-dc13ad55cd310f13223818d9fc64ac1eea8e4a1b.tar
guix-dc13ad55cd310f13223818d9fc64ac1eea8e4a1b.tar.gz
guix-dc13ad55cd310f13223818d9fc64ac1eea8e4a1b.tar.bz2
guix-dc13ad55cd310f13223818d9fc64ac1eea8e4a1b.tar.lz
guix-dc13ad55cd310f13223818d9fc64ac1eea8e4a1b.tar.xz
guix-dc13ad55cd310f13223818d9fc64ac1eea8e4a1b.tar.zst
guix-dc13ad55cd310f13223818d9fc64ac1eea8e4a1b.zip
gnu: Add rust-windows-0.57.
Change-Id: I893b503619975a38c4100bcbff983bce3562175b
-rw-r--r--gnu/packages/crates-windows.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/crates-windows.scm b/gnu/packages/crates-windows.scm
index 8d45d4f13c..a6a8ed20bc 100644
--- a/gnu/packages/crates-windows.scm
+++ b/gnu/packages/crates-windows.scm
@@ -1352,6 +1352,30 @@ describing the API and right into your Rust package where you can call them as
if they were just another Rust module.")
(license (list license:expat license:asl2.0))))
+(define-public rust-windows-0.57
+ (package
+ (name "rust-windows")
+ (version "0.57.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "windows" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0hqid10bqvxa3pbpgvrh2cilf950lxsd9zqfv3rldc73v2s2qd0j"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-windows-core" ,rust-windows-core-0.57)
+ ("rust-windows-targets" ,rust-windows-targets-0.52))))
+ (home-page "https://github.com/microsoft/windows-rs")
+ (synopsis "Rust for Windows")
+ (description
+ "The windows crate lets you call any Windows API past,
+present, and future using code generated on the fly directly from the metadata
+describing the API and right into your Rust package where you can call them as
+if they were just another Rust module.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-windows-0.52
(package
(inherit rust-windows-0.58)