aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve George <steve@futurile.net>2024-10-04 20:59:56 +0000
committerEfraim Flashner <efraim@flashner.co.il>2024-10-10 11:46:26 +0000
commitaa3790a22389842b0a4469645c0b460f69fcd793 (patch)
tree7ed576c37277e7230c4bfe6103d1a082141d69b3
parente4ae18c93805fdabb89694821c630fd754f96e96 (diff)
downloadguix-aa3790a22389842b0a4469645c0b460f69fcd793.tar
guix-aa3790a22389842b0a4469645c0b460f69fcd793.tar.gz
guix-aa3790a22389842b0a4469645c0b460f69fcd793.tar.bz2
guix-aa3790a22389842b0a4469645c0b460f69fcd793.tar.lz
guix-aa3790a22389842b0a4469645c0b460f69fcd793.tar.xz
guix-aa3790a22389842b0a4469645c0b460f69fcd793.tar.zst
guix-aa3790a22389842b0a4469645c0b460f69fcd793.zip
gnu: Add rust-object-pool-0.5.
* gnu/packages/crates-io.scm (rust-object-pool-0.5): New variable. Change-Id: I187305adf24f3377e2be4747d6fcdf0c610bd754
-rw-r--r--gnu/packages/crates-io.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index edad2d3e65..f39bc3a1a0 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -49991,6 +49991,32 @@ file formats.")
("rust-rustc-std-workspace-core" ,rust-rustc-std-workspace-core-1)
("rust-wasmparser" ,rust-wasmparser-0.57))))))
+(define-public rust-object-pool-0.5
+ (package
+ (name "rust-object-pool")
+ (version "0.5.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "object-pool" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0s4d6bap4b4fazz4izgqvrc6si4fdrbz2fdr09hci7nhjrqkx6pf"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-test-flags ; Skip the doctests.
+ '("--release" "--lib" "--bins" "--tests")
+ #:cargo-inputs (("rust-parking-lot" ,rust-parking-lot-0.11))
+ #:cargo-development-inputs (("rust-criterion" ,rust-criterion-0.3)
+ ("rust-criterion-plot" ,rust-criterion-plot-0.4))))
+ (home-page "https://github.com/CJP10/object-pool")
+ (synopsis
+ "Thread-safe object pool with automatic return and attach/detach semantics")
+ (description
+ "This package provides a thread-safe object pool with automatic return and
+attach/detach semantics.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-object-store-0.9
(package
(name "rust-object-store")