aboutsummaryrefslogtreecommitdiff
path: root/dwm
diff options
context:
space:
mode:
authorLuca Matei Pintilie <lucafulger@gmail.com>2022-02-11 16:35:29 +0000
committerLuca Matei Pintilie <lucafulger@gmail.com>2022-02-11 16:35:29 +0000
commite54014dffba9ca9db6f9088017f18fbf4fb02d6e (patch)
tree15cc644ddf7ce3ed353c5d87b0737029da322da8 /dwm
parent4417eb0a77892f4b24eeb5adc97b8890f14187fb (diff)
parenta6756c60d5481e6b679cbca0369c0d56076de95c (diff)
downloaddotfiles-e54014dffba9ca9db6f9088017f18fbf4fb02d6e.tar
dotfiles-e54014dffba9ca9db6f9088017f18fbf4fb02d6e.tar.gz
dotfiles-e54014dffba9ca9db6f9088017f18fbf4fb02d6e.tar.bz2
dotfiles-e54014dffba9ca9db6f9088017f18fbf4fb02d6e.tar.lz
dotfiles-e54014dffba9ca9db6f9088017f18fbf4fb02d6e.tar.xz
dotfiles-e54014dffba9ca9db6f9088017f18fbf4fb02d6e.tar.zst
dotfiles-e54014dffba9ca9db6f9088017f18fbf4fb02d6e.zip
Merge branch 'master' of aninternettroll.xyz:aninternettroll/dotfiles
Diffstat (limited to '')
-rwxr-xr-xdwm/.dwm/autostart29
-rwxr-xr-xdwm/.dwm/bar/bar.sh14
-rw-r--r--dwm/.dwm/xresources53
-rw-r--r--dwm/chadwm/Makefile7
-rw-r--r--dwm/chadwm/config.def.h8
5 files changed, 87 insertions, 24 deletions
diff --git a/dwm/.dwm/autostart b/dwm/.dwm/autostart
index 532f13c..71595cc 100755
--- a/dwm/.dwm/autostart
+++ b/dwm/.dwm/autostart
@@ -2,19 +2,34 @@
# How2bind???
#setxkbmap -layout us,no -option grp:ctrl_win_l_toggle
+setxkbmap -layout no
picom --vsync --no-fading-openclose --refresh-rate "59.96" &
xrdb merge ~/Public/xresources/forest/.Xresources &
-feh --bg-tile ~/Pictures/wall/bee.jpg &
+feh --auto-reload --bg-fill ~/Pictures/wall.jpg &
# Set up touchpad controls
-TID=$(xinput | sed -n 's/.*Touchpad.*id=\([0-9]*\).*/\1/p')
+
+# Libinput
+#TID=$(xinput | sed -n 's/.*Touchpad.*id=\([0-9]*\).*/\1/p')
+#xinput --set-prop $TID 'libinput Accel Speed' 0.5
+#xinput --set-prop $TID 'libinput Tapping Enabled' 1
+#xinput --set-prop $TID 'libinput Natural Scrolling Enabled' 1
#xinput --set-prop $TID 'libinput Accel Speed' 0.5
-xinput --set-prop $TID 'libinput Tapping Enabled' 1
-xinput --set-prop $TID 'libinput Natural Scrolling Enabled' 1
+
+# Synapse
+TID=`xinput list | grep "SynPS/2 Synaptics TouchPad" | sed 's/.*id=\([0-9]*\).*/\1/g'`
+PROP_NO=`xinput list-props ${TID} | grep "Synaptics Scrolling Distance" | sed 's/.*(\([0-9]*\)).*/\1/g'`
+#xinput --set-prop $TID 'Synaptics Tap Action' 1
+xinput set-prop ${TID} ${PROP_NO} -106 -106
# run bar script and dwm ( do not remove this )
-SYMLINKDIR=(readlink -f "$0")
+SYMLINKDIR=$(readlink -f "$0")
BASEDIR=$(dirname "$SYMLINKDIR")
-$BASEDIR/.dwm/bar/./bar.sh &
+$BASEDIR/bar/./bar.sh &
+xrdb merge $BASEDIR/xresources &
+
+dunst &
+nm-applet &
+light-locker --lock-on-suspend &
-dwm
+dbus-run-session dwm
diff --git a/dwm/.dwm/bar/bar.sh b/dwm/.dwm/bar/bar.sh
index 89cfdf4..6dafda4 100755
--- a/dwm/.dwm/bar/bar.sh
+++ b/dwm/.dwm/bar/bar.sh
@@ -6,10 +6,10 @@
interval=0
# run bar script and dwm ( do not remove this )
-SYMLINKDIR=(readlink -f "$0")
+SYMLINKDIR=$(readlink -f "$0")
BASEDIR=$(dirname "$SYMLINKDIR")
# load colors!
-. $BASEDIR/.dwm/bar/themes/onedark
+. $BASEDIR/themes/onedark
cpu() {
cpu_val=$(grep -o "^[^ ]*" /proc/loadavg)
@@ -20,7 +20,7 @@ cpu() {
pkg_updates() {
#updates=$(doas xbps-install -un | wc -l) # void
- updates=$(checkupdates | wc -l) # arch , needs pacman contrib
+ #updates=$(checkupdates | wc -l) # arch , needs pacman contrib
# updates=$(aptitude search '~U' | wc -l) # apt (ubuntu,debian etc)
if [ -z "$updates" ]; then
@@ -44,8 +44,8 @@ battery() {
}
brightness() {
- brightness="$(cat /sys/class/backlight/*/brightness)"
- brightness_max="$(cat /sys/class/backlight/*/max_brightness)"
+ brightness="$(cat /sys/class/backlight/intel_backlight/brightness)"
+ brightness_max="$(cat /sys/class/backlight/intel_backlight/max_brightness)"
level=$(echo "scale=2; $brightness / $brightness_max * 100" | bc)
printf "^c$red^  "
@@ -91,8 +91,8 @@ keyboard() {
while true; do
- [ $interval = 0 ] || [ $(($interval % 3600)) = 0 ] && updates=$(pkg_updates)
+ #[ $interval = 0 ] || [ $(($interval % 3600)) = 0 ] && updates=$(pkg_updates)
interval=$((interval + 1))
- sleep 1 && xsetroot -name "$updates $(battery) $(brightness) $(cpu) $(mem) $(keyboard) $(wlan) $(volume) $(clock)"
+ sleep 1 && xsetroot -name "$updates $(battery) $(brightness) $(cpu) $(mem) $(wlan) $(volume) $(clock)"
done
diff --git a/dwm/.dwm/xresources b/dwm/.dwm/xresources
new file mode 100644
index 0000000..018a8dd
--- /dev/null
+++ b/dwm/.dwm/xresources
@@ -0,0 +1,53 @@
+!-- Xft settings -- ! you dont even need this probably
+
+Xft.antialias: 1
+Xft.hinting: 1
+Xft.autohint: 0
+Xft.hintstyle: hintslight
+Xft.rgba: rgb
+Xft.lcdfilter: lcddefault
+
+! transparency ( 0.1 to 0.9 values)
+st.alpha: 0.8
+
+! inner padding
+st.borderpx: 15
+st.font: JetBrainsMono Nerd Font:style:medium:pixelsize=15
+
+!! Colors
+
+!! Dracula palette
+*.foreground: #F8F8F2
+*.background: #282A36
+
+!! black + grey
+*.color0: #000000
+*.color8: #4D4D4D
+
+!! dark red + red
+*.color1: #FF5555
+*.color9: #FF6E67
+
+!! green
+*.color2: #50FA7B
+*.color10: #5AF78E
+
+!! yellow
+*.color3: #F1FA8C
+*.color11: #F4F99D
+
+!! purple
+*.color4: #BD93F9
+*.color12: #CAA9FA
+
+!! pink
+*.color5: #FF79C6
+*.color13: #FF92D0
+
+!! cyan
+*.color6: #8BE9FD
+*.color14: #9AEDFE
+
+!! white
+*.color7: #BFBFBF
+*.color15: #E6E6E6
diff --git a/dwm/chadwm/Makefile b/dwm/chadwm/Makefile
index 3341ec3..c05dbdd 100644
--- a/dwm/chadwm/Makefile
+++ b/dwm/chadwm/Makefile
@@ -4,9 +4,7 @@
include config.mk
SRC = drw.c dwm.c util.c
-cfiles = $(wildcard ./*.c)
-hfiles = $(wildcard ./*.h)
-ofiles = $(cfiles:.c=.o)
+OBJ = ${SRC:.c=.o}
all: options dwm
@@ -50,7 +48,4 @@ uninstall:
rm -f ${DESTDIR}${PREFIX}/bin/dwm\
${DESTDIR}${MANPREFIX}/man1/dwm.1
-format:
- clang-format -i -style=file $(cfiles) $(hfiles)
-
.PHONY: all options clean dist install uninstall
diff --git a/dwm/chadwm/config.def.h b/dwm/chadwm/config.def.h
index ee17db6..b49ef88 100644
--- a/dwm/chadwm/config.def.h
+++ b/dwm/chadwm/config.def.h
@@ -122,13 +122,13 @@ static const Layout layouts[] = {
/* commands */
static char dmenumon[2] = "0"; /* component of dmenucmd, manipulated in spawn() */
static const char *dmenucmd[] = {"dmenu_run", NULL};
-static const char *termcmd[] = {"alacritty", NULL}; // change this to your term
+static const char *termcmd[] = {"st", NULL}; // change this to your term
static const char *rofi[] = {"rofi", "-show", "drun", NULL};
static const char *xi[] = {"xbacklight", "-inc", "7", NULL};
static const char *screenshotcmd[] = {"flameshot", "gui", NULL};
static const char *xd[] = {"xbacklight", "-dec", "7", NULL};
-static const char *volume_up_cmd[] = {"pamixer", "-i", "5", NULL};
-static const char *volume_down_cmd[] = {"pamixer", "-d", "5", NULL};
+static const char *volume_up_cmd[] = {"pamixer", "--allow-boost", "-i", "5", NULL};
+static const char *volume_down_cmd[] = {"pamixer", "--allow-boost", "-d", "5", NULL};
static const char *volume_mute_toggle[] = {"pamixer", "-t", NULL};
static const char *keyboard_brightness_up[] = {"xbacklight", "-ctrl", "asus::kbd_backlight",
"-inc", "33", NULL};
@@ -137,7 +137,7 @@ static const char *keyboard_brightness_down[] = {"xbacklight", "-ctrl", "asus::k
static const char *player_toggle[] = {"playerctl", "play-pause", NULL};
static const char *player_next[] = {"playerctl", "next", NULL};
static const char *player_previous[] = {"playerctl", "previous", NULL};
-static const char *screen_lock[] = {"xsecurelock", NULL};
+static const char *screen_lock[] = {"light-locker-command", "-l", NULL};
static Key keys[] = {
/* modifier key function argument */