aboutsummaryrefslogtreecommitdiff
path: root/dwm/chadwm
diff options
context:
space:
mode:
authorLuca Matei Pintilie <lucafulger@gmail.com>2022-02-11 16:35:29 +0000
committerLuca Matei Pintilie <lucafulger@gmail.com>2022-02-11 16:35:29 +0000
commite54014dffba9ca9db6f9088017f18fbf4fb02d6e (patch)
tree15cc644ddf7ce3ed353c5d87b0737029da322da8 /dwm/chadwm
parent4417eb0a77892f4b24eeb5adc97b8890f14187fb (diff)
parenta6756c60d5481e6b679cbca0369c0d56076de95c (diff)
downloaddotfiles-e54014dffba9ca9db6f9088017f18fbf4fb02d6e.tar
dotfiles-e54014dffba9ca9db6f9088017f18fbf4fb02d6e.tar.gz
dotfiles-e54014dffba9ca9db6f9088017f18fbf4fb02d6e.tar.bz2
dotfiles-e54014dffba9ca9db6f9088017f18fbf4fb02d6e.tar.lz
dotfiles-e54014dffba9ca9db6f9088017f18fbf4fb02d6e.tar.xz
dotfiles-e54014dffba9ca9db6f9088017f18fbf4fb02d6e.tar.zst
dotfiles-e54014dffba9ca9db6f9088017f18fbf4fb02d6e.zip
Merge branch 'master' of aninternettroll.xyz:aninternettroll/dotfiles
Diffstat (limited to '')
-rw-r--r--dwm/chadwm/Makefile7
-rw-r--r--dwm/chadwm/config.def.h8
2 files changed, 5 insertions, 10 deletions
diff --git a/dwm/chadwm/Makefile b/dwm/chadwm/Makefile
index 3341ec3..c05dbdd 100644
--- a/dwm/chadwm/Makefile
+++ b/dwm/chadwm/Makefile
@@ -4,9 +4,7 @@
include config.mk
SRC = drw.c dwm.c util.c
-cfiles = $(wildcard ./*.c)
-hfiles = $(wildcard ./*.h)
-ofiles = $(cfiles:.c=.o)
+OBJ = ${SRC:.c=.o}
all: options dwm
@@ -50,7 +48,4 @@ uninstall:
rm -f ${DESTDIR}${PREFIX}/bin/dwm\
${DESTDIR}${MANPREFIX}/man1/dwm.1
-format:
- clang-format -i -style=file $(cfiles) $(hfiles)
-
.PHONY: all options clean dist install uninstall
diff --git a/dwm/chadwm/config.def.h b/dwm/chadwm/config.def.h
index ee17db6..b49ef88 100644
--- a/dwm/chadwm/config.def.h
+++ b/dwm/chadwm/config.def.h
@@ -122,13 +122,13 @@ static const Layout layouts[] = {
/* commands */
static char dmenumon[2] = "0"; /* component of dmenucmd, manipulated in spawn() */
static const char *dmenucmd[] = {"dmenu_run", NULL};
-static const char *termcmd[] = {"alacritty", NULL}; // change this to your term
+static const char *termcmd[] = {"st", NULL}; // change this to your term
static const char *rofi[] = {"rofi", "-show", "drun", NULL};
static const char *xi[] = {"xbacklight", "-inc", "7", NULL};
static const char *screenshotcmd[] = {"flameshot", "gui", NULL};
static const char *xd[] = {"xbacklight", "-dec", "7", NULL};
-static const char *volume_up_cmd[] = {"pamixer", "-i", "5", NULL};
-static const char *volume_down_cmd[] = {"pamixer", "-d", "5", NULL};
+static const char *volume_up_cmd[] = {"pamixer", "--allow-boost", "-i", "5", NULL};
+static const char *volume_down_cmd[] = {"pamixer", "--allow-boost", "-d", "5", NULL};
static const char *volume_mute_toggle[] = {"pamixer", "-t", NULL};
static const char *keyboard_brightness_up[] = {"xbacklight", "-ctrl", "asus::kbd_backlight",
"-inc", "33", NULL};
@@ -137,7 +137,7 @@ static const char *keyboard_brightness_down[] = {"xbacklight", "-ctrl", "asus::k
static const char *player_toggle[] = {"playerctl", "play-pause", NULL};
static const char *player_next[] = {"playerctl", "next", NULL};
static const char *player_previous[] = {"playerctl", "previous", NULL};
-static const char *screen_lock[] = {"xsecurelock", NULL};
+static const char *screen_lock[] = {"light-locker-command", "-l", NULL};
static Key keys[] = {
/* modifier key function argument */